Scale/Size problem in Preform software


#1

I have been modelling in 3ds Max 2014, all units in UI set to mm, the model section is approx 158mm in length. I open it in meshlab and netfabb and both confirm size at approx 158mm, but when I import to Preform the scale is way off the mark. any thoughts would be greatly appreciated.


#2

Ok update. I modelled a box the same size as the Form print volume, and sent that to preform and the scale was 100% accurate. I then added the model mesh to the box and exported that to preform and the scale was all out of whack again. I am REALLY confused!


#3

I have noticed that when I have a part bigger than the build volume they are reduced in size to fit.  I have not worked out how the software decided on the reduction but some parts do come in much smaller than the volume itself.  I am sure there is a pattern to it somewhere.  Anything small enough to fit within the volume has imported perfectly so I find it interesting you are seeing this issue.

Do you have any scale factors in operation in your software (not sure how 3ds Max 2014 works)?

Can you share the stl file for us to look at?


#4

The object was modeled at 100% scale and should fit into the Form1 volume, albeit with a tight squeeze, I have attached the file.

Front_Upper_Receiver_Shell_binary.stl


#5

Yes, this is a known issue with how we handle scaling and setting the units to load a model with.  It’s already been addressed and will ship in the next version. :slight_smile:


#6

Ok, it looks like it might be a size issue - if I rotate it inside the print volume the vertical gap is as  small as 1.38 mm, but if left vertical it’s 7.3 mm. I’m assuming the software is analysing the object prior to import ready for orientation - maybe this isn’t enough clearance?


#7

OK I have imported the stl file as supplied into Preform and it does what you have identified.

I then imported it into Sketchup and the containing cube you have drawn is 3175mm x 3175mm x 4191mm tall so the proportions are way too big for the volume of the printer.  I deleted the containing frame you added and then exported to stl.  The file imported into preform as shown below.

Before we go any further there were some issues with the file import other than size.  The file is not watertight so you need to look at that before you print.

I am not an expert with 3D software by a long way but is looks like your stl file in some way is getting rendered way too big from your original drawing, but I am no expert!


#8

Hmm, and therein lies the crux of my dilemma - none of the software I used to check my model showed the dimensions to be anything other than those i originally setup. When I reduced the length of the mesh by 30mm it did fit (but obviously I can’t go changing dimensions willy nilly just to fit the volume!)

By breaking the mesh up into 2 smaller sections I have been able to fit, but with other issues now apparent - obviously not a fix then! I was aware of some errors with the mesh but again this is giving me a headache as meshlab and net fabb both stated the mesh was error free, although Preform did not. Grrr :-/


#9

Nigel, the dimensions you stated when divided by the true measurements gave a value of 25.4 - (1 inch = 25.4mm) so it looks very ,much like a units issue in 3ds Max which I will have to address.


#10

Well spotted.  While there is an issue with the pre-form software I suspect there might be something on your side to sort out also.  I’ll see if I can fix the leaks and forward something that has been resized with that scale error removed :slight_smile:


#11

Sorted the leaks out quicker than I thought!!   Attached the revised .stl  reduced by scale factor 0.39370071.   Use this as a guide as it’s not the best way to size things up I suspect.  Does it look the right size now (see the dimensions in the screen dump).

zzzz_2.stl


#12

Forgot the screen dump!


#13

Nice one Nigel, the drop in scale is quite significant so wouldn’t be acceptable for the final print but now that I know (think I know!) the problem I should be able to prevent it occurring again. What software were you using to detect/fix the errors btw?


#14

I use the simplest of them all.  Sketchup with a few select plugins.  I draw small items but usually I start by drawing them 10 x or 100 x original size as it is useless for drawing small items to scale.  Plugins are used to import and export STL and to check for leaks.


#15

Thanks to Nigel and Max for your input on this one (still not sure why netfabb is saying model fixed, but preform still states errors, still, you can’t have everything!)

btw Nigel, what errors were you detecting fixing?


#16

There were a few holes in the structure.  See images below for location.

Onwards . . . .


#17

I have a similar problem to JasonSpiller in that my import from an Autodesk Inventor .stl file is appearing super small and off scale/dimension. This is a modified image of a part that I have already had a machine shop produce, so I know that there isn’t any issue with the file. I was hoping to test the modified part by printing a version before sending it out yet I am hung up on this one detail. I should add that I am using the Form 2.



#18

I always make note of the size just in case then confirm it on import. Should be easy enough to type in the dimensions again if it does go off.
I did have a part that was larger than the print area and PreForm did scale it on me so I scaled it back to where it should have been and angled it to fit the build area. All worked out well.


#19

@KenCitron, thanks for the advice. I was able to get it to scale by adjusting the z axis dimension in relation to my Inventor drawing. It would nice if I didn’t have to adjust scaling as I assume that when I produce more complex parts that these dimensions won’t be so easy to translate over to the printer.


#20

Hi, i am printing on the Formlabs 2, and i am have the exact same scaling issue.

I just want to clarify what your saying. If i adjust the Z axis in the Preform program according to the Z axis in my 3D program (Cinema4D) it should be to correct scale?

Thank You in advance