For Solidworks users

I mentioned a few days back I was having big problems getting by items to size correctly in the printer programs. I first had the issue with my Cube (which I just got back from 3D Systems today) and was blaming it on their awful Cubify program. But I was livid when I had the same problems with the Form1 program too. If I could not make my items in Solidworks I wasted buying 2 printers!

I contacted my Solidworks help. He installed the Cubify and Form1 programs.

I am still not convinced this was my issue but I am having better results. This is what he said. When you save from SLDPRT to STL there is a screen where you can chose advanced options. That is where you can AND SHOULD use the slider to increase resolution (once - it will stay there), but you have to make sure it is set to the units (inches or MM) you designed in. I always design in inches. When the printer programs ask MM or inches you chose there as well.

I have various years of Solidworks from 2008 to 2014, soon to be 2015, and depending on the computer I am using. I am starting to think my problems came from me still using 2008 most of the time because I am used to it. When I save a 2008 file in 2012 I have had good success so far. That also eliminates 2008 from opening it again though.

BTW for Form1 employees still reading this, the Cubify program really IS awful compared to the From1 program. It is clunky, and not intuitive. Just awful!


I too model in inches usually but keep the PreForm in mm since the layers are also slices. So far things seem to be pretty accurate. I do majority of my models out of MOI 3d and don’t have any scale issues in PreForm.

Not sure how efficient SolidWorks is for exporting stl files (curvature tesselation, min/max tesselation). Inaccuracies could be from a low tessellated model.

What would be really nice is if PreForm could import 3dm, igs and step files directly rather than just the cooked out poly models like stl and obj.

I use SW too, when you do your “save as” .STL there is an options box click on that, there are options for Course, Fine, and Custom. I do fine or custom typically. Also you can choose the units you export out your parts. Also if you design in Assemblies or multi-bodies make sure you have “Save all components(bodies) in a single file” checked.

I mostly work in solidworks and have never had a scaling issue form stl files. Like others have said, check to make sure you are outputting high resolution stl’s and it should fix the problem for you. I would also recommend using mm for your stl files as that is the standard across the board for any software using this file type.

Another SolidWorks user…

I typically model in inches, but if you set the stl export units to mm they import correctly into PreForm.

I have used SW since 2007 and have been certified since 2010. I have owned 3D printers for three years. So, I will share what little I know…

When trying to get the best surface resolution from your STL file, use these four tips.

  1. Save as STL
  2. Open Options box
  3. Don’t worry so much about the actual numerical value here, just slide to within a 1/4 inch of the right
  4. I typically use about 6 degrees which works for me
    Your units must match the units you will using in the print. It doesn’t matter inch or metric, but it MUST match.

That’s all there is to it. Happy printing.