Resin tank fill error of Form2 3D printer

Recently I got my Form2 3D printer, but when I insert the resin tank and start to test, it always shows me the resin tank fill error.

And sometimes it start to leak resin into the tank, but a few minutes later it stopped with the tank fill error, when i check the original appearance, it shows me the tank unused, how could i do with this?

Also i found the original appearance is different with most of them, I will attatched two pictures for you us guys to refer to.

Please guide me to solve it.



you guys are welcomed to send me emails via or via skype :winson-qi

The first time I ran my F2 it said “tank fill error”. Even though it put resin in the tank. I restarted it and it added a little more resin and then started printing (but I was ready to abort the print if it didn’t stop adding resin).

The printer can’t “meter” the resin it puts in to the tank. It depends on the resin flowing out at a known rate, and it uses “time” as the parameter to control how much resin it allows to leave the cartridge. But it knows when the tank is full using a detector which is located at the base of the Z-axis stage at the back of the printer. As a safety measure, to prevent overfilling, the printer probably “aborts” the tank filling process if it takes longer than some maximum time before the sensor detects that the tank is full. In case the sensor is blocked somehow, or it fails.

In my case, the flow rate from the cartridge must have been a little slower than the printer expected, so it tried to fill the tank until the time limit expired and then it gave up. But when I restarted the print, the tank was already mostly full, so a little additional resin was quickly added and the printer started running.

Be sure your printer has the latest Firmware.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.