Form 2 resin tank never stops filling the tray

The 2 arrived today.

The resin tank never stops draining, since the closure never activates. The tray overfilled, and the wiper pushed a bit of resin over the edge.

Luckily I was babysitting the first fill and caught it in time to prevent a flood.

I cleaned the chip on the tray and on the tank. LCD reads “Resin Tank Unused” and Cartridge “Tough”.

Tried unplugging the machine and then restarting. No luck.

Anyone else had this happen, and what fixed it, if anything?

Thanks for your help!

Rob, this is definitely not expected behavior and a rare occurrence out in the field. Please send us a ticket so our Form 2 techs can take a look and help resolve this for you asap.


Well, not the printer, turns out.

The tank won’t fill until you start a print. The repair is to note this in the set up instructions.

It just wouldn’t occur to me to go on to fire off a print if the tank wouldn’t fill!!!

All seems well now.

Sorry, left out a step here; when the tank wouldn’t fill, I removed the cartridge and manually opened the slit; I had thought I had closed it and it was ok to reinsert, but obviously the ensuing overfill was a consequence of doing that poorly.

I’m using the same cartridge now, after reinserting it again, after checking the valve. Still looked that same. Not sure just what I did that wouldn’t let it reseal, but it ain’t no nevermind. All is well now. Running the first print.

Working is working.

There’s some very clever intelligence in the 2. A major improvement!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.