Resin does not fill tank

Hello, i am having troubles starting my print. The print gets stuck at “filling resin tank” for around 30 min. then displays an error message that the cartridge is either jammed or empty and the tank cannot be filled. When I look at the area where the resin should drip down while filling the tank, I don’t see any resin at all coming down from the cartridge. Is it possible that the dispense arm has an issue?

I checked the following things:

  • The cartridge is new and was used for a print 2 days ago.

  • the bite valve is ok and resin can flow out when squeezed

  • the printer has the newest firmware

  • preform is up to date

  • the cartridge cap is open and air can flow through

  • shaked the cartridge

  • levelled and rebooted the printer

  • calibrated the level sensor

  • unplugged the printer for 30 min

all of the things listed above did not solve the issue, the resin tank still does not fill. I can’t think of anything else and hope you guys here might have an idea.

Most likely the cartridge is empty. Clicking the continue button will allow the print to start, but if your print takes more than ~300 ml of resin it may not finish.

The real answer is to buy more resin.

I don’t think an empty cartridge is the problem, since the cartridge is almost new (around 80%). The problem is that there is no resin flow from the cartridge to the tank at all. On my other Form 3 you see a constant flow of resin in the tank when filling.

Does the printer recognize the cartridge when you insert it? I have had issues with some cartridges not filling because the printed did not recognize that a cartridge had been inserted. I had so “slam” or forcefully insert the cartridge for the printer to recognize it was inserted. It was like the printer couldn’t “find” the cartridge.

One easy way to check if it’s the cartridge of the printer is the swap the cartridge to your other printer see if it goes into the tray…that would at least let you tell if its the printer"s resin dispensing arm or not

  • Yes it does recognize the cartridge.

I tried two things to rule out the cartridge as a problem:

  1. I took the bite valve of another cartridge that worked before - same issue
  2. I poured the resin into another empty cartridge that worked before - same issue…

So can the dispenser arm really be the root of the problem here? I haven’t found anything so far about broken dispenser arms…

I would contact support…

Yeah, I have - it does take quite some time to get a response though, that’s why I was hoping to maybe find some answers here. I will update if I find a solution through support.

I am having the same issue, and saw it with two other machines last week

When this happens, I carefully insert a #11 Xacto knife blade in to the slit in the bite valve to open it up. The problem appears to be that that slit isn’t always cut quite deep enough in to the valve so even when it’s squeezed the valve doesn’t open. You have to be careful though, because if you cut too much the valve will leak even when closed, and that’ll flood your printer with resin…

1 Like

This has happened to me too, even when I know the cartridge is almost full. I have a Form3.
1- Try ckeaning and pinching the bite valve at the bottom of the cartridge
2- Take the cartridge out and re-insert it
3- If the vat is nearly empty it can take a while to fill it up, so you may want to pour some resin into the vat manually
4- Make sure the level float is not stuck

Good luck

I figured out the problem. I had the same issues as you. So what is happening is that the resin container is clogged. even if it’s new and has been sitting with the rubber spout down the resin will coagulate over time so when you go to print it is jammed. To solve this I just used a small dowel. you can use anything really that fits in the hole. I gently moved the dowel around clearing the coagulated resin which came out in globs. Once I did this the resin was coming out in a fluid stream and i was good to go.

1 Like

Thanks for the reply everyone, I got a new dispenser arm from formlabs but this did not solve the issue either. In the end I got a replacement printer since it was still in warranty. I figure the motor or the motor control itself were broken. With the new printer all the tried cartridges work just fine.


Thanks a lot. It works perfectly

1 Like

Is there anyway to verify the resin dispensing arm is working? The bite value is fine I took it apart and i can manually get resin to drip out. I dont think the arm is pressing on the value but I have no way of knowing that because I cant see it.

Is there a way to check the resin dispensing arm? Like some backend way of seeing if its working?

Unfortunately Formlabs did not provide any Info to me on how to check the dispenser arm seperately…

I was having the same issue and I tried basically everything mentioned here too, without any immediate success.

Like others also mentioned, in the quest for what the problem was I ultimately narrowed it down to (guessing) that the valve actuator which opens the rubber drip outlet must be faulty, since it flows fine when manually pushing the rubber nozzle on the cartridge.

but when the form3 is supposed to be “filling up the tank” there is not a drop to hit the floor for a few hours until the printer finally enters time out error.

Days prior to this, the printer was giving notifications about no cartridge detected while there is a full one in the machine.

Anyways In my case though, getting frustrated with the hours of my day wasted I kept trying and checking by reinstalling the cartridge over and over and in the process I ended up “dunking” the cartridge down into the slot of the form3 with increasing amount of force, which ultimately led to a perfectly functional printer and the problem never returned afterwards.

Maybe it’s a bug where the droplet actuator somehow gets locked up and needs a thud to unjam? Just a thought

Hi @ThomasHouterman,

Just wanted to check in and make sure that you were in touch with our Support Team; they should be able to take a look at logs and any photos/videos you submit to help get things back to running smoothly.