Removing rigid 10k rafts from build platform

I just made my second print ever with the form 3. I used the rigid 10k resin and holy crap this stuff is bordering on impossible to remove from the build platform.

I’ve been chipping away at it periodically until I get bored for a day now. I got a better scrapper from home depot. I’ve used a heat gun on it with limited results. We have a -40F freezer at work as well where I put it in for 30 minutes and still barely helped.

I still haven’t removed all of it, but now my build platform has scratches and dents
from the scrapper and the heat gun melted some of the glue on the platform so one of the sides popped off.

Do I just keep going it it with the scrapper and heat gun?

Do I need a new build platform after this? I think some of the scratches are a little deep?

1 Like

Some hot boiling water and a sharp flat knife should do the trick the peel the part of the platform.

That’s odd. My prints with Rigid 10k literally snap out of the build plate just by touching them both in the Form 3 and 3L.
Even the supports come out with almost no pressure at all.
When something needs to be removed from the build plate with a sledgehammer then something went wrong.

Full rafts do use more vacuum and pressure so if you’re struggling with those try the mini rafts. They do the same with less resin and way less removal effort.

Scratches aren’t an issue. Deep ones may or not be an issue. Just try to print something in that area and see how it goes.

I use one of these

You have to be really careful with it, of course. But it is a thin, strong, sharp steel blade that can be worked under the edge of even the most balky prints, after which a simple twist of the blade is usually enough to pop the print off.


I had the exact same problem. Even with a razor I couldn’t get under the raft. When I tried prying up under the raised lip it just fractured away leaving the rest of the raft bonded to the build plate. Ended up using a hammer and a rigid 1-1/2" putty knife to chisel it away. What a nightmare!

While attempting to get under the raft with any sort of scraper / blade is advisable it doesn’t work every single time. When it doesn’t just use the provided plier (the angled one) to snip a tiny bit of a corner of the raft. After that just insert the scraper (the one that comes with the 3L is amazing for that) and gently work your way under the raft. No force is needed, just let the air do its thing.

Razors won’t do anything better than a scraper because the raft is held by vacuum which means that using a razor will only scratch the surface (literally and figuratively). Even a chisel and a hammer won’t help much. Once you can get air in (using the included plier’s if you can’t do it normally) everything else is just a matter of making way for more air to get through.

And yes, I also started doing it the wrong way.