Removed/Missing Cartridge Error with newer cartridges

Hi everyone

I already had some problems with the printer, but the current “Missing Cartridge Error” is really tricky and I don’t get it solved.
I started my first prints with Clear V2 and never had any problems, then I got Clear V4, White V4 and Flexible V2. Since then the cartridge sensor drives me crazy.
What I found out while watching the printer is, that the printer shows the message “Cartridge removed” (and/or “Unknown Consumable Removed”) only when the tank starts to move to the right after a layer is done. Sometimes it immediately shows “Cartridge inserted” so the print continues. With the flexible material these messages are shown more often while the tank is moving, as the it moves much slower than with the standard materials. Unfortunately at one point the cartridge is not recognized anymore and the print stops with the “Missing Cartridge Error” until I remove and insert the cartridge manually. Which is very annoying when printing overnight…

I think the cartridges or the chip is very missplaced in relation to the sensor pins inside. The vibrations of the moving tank does the rest to disconnect the chip from the pins. I could see that from the fine marks on the chip from the sensor pins. They are never centered.

I’ve tried using some layers of tape around the bottom of the cartridge to center the sensor pins to the chip and get rid of the huge tolerances but it only worked once with the Clear V4. The Flexible V2 still doesn’t work with the tape.
I also replaced the whole cartrige floor but no improvement at all.

Do you have any other suggestions?

Maybe this will help. Try cleaning chip with rubbing alcohol. My Form 2 didn’t recognize one cartridge when inserted. Cleaning the chip helped.

Thanks matej. The chip is clean though and I cleaned it anyway just to make sure.

I’m currently investigating what the real problem is and I’ve found something very interesting. As I thought it’s definitely the cartridge dimensions/tolerance. When I insert the Clear V2 that worked perfectly I can do what I want it always recognize it.
With the Flexible V2 cartridge, when it’s inserted and I shake or move it a bit it looses contact and shows the “Cartridge removed” message. So the chip it kind of missplaced in relation to the sensor pins. I will now measure both cartridges to see where it should be and where I can put some tape to have a stable contact.
Not satisfying at all because it’s hardware related but at least I’m getting closer…

I do have the same problem with my printer…
and there are a lot of threads about that problem with different suggestions.

My journey so far:
The printer is quite new. (about 300 hours working)
I have different resins in use. (grey, clear, white, black and model)
After about 150 working hours it started with continuing “missing cartridge errors”.
It started with a cartridge which was working fine and overnight working was no problem.
Now with that problem a 6 hours print takes about 9 hours to finish.
The problem appears mainly at the beginning of a print and only occasionally in the middle part of the process.
I`ve tried all these things and nothing helps:

  • cleaning the contacts both inside and outside – nope
  • contact oil /spay – nope
  • new / old cartridge which was working before fine – nope
  • tape around ore under the cartridge – nope
  • a plastic sheet between cartridge and printer to hold / press the cartridge tighter in position –nope
  • software / firmware update – nope

The only suggestion from Formlabs so far was that tape around the cartridge and to call the support…
But is there really a solution for that problem? Then Formlabs, please let us know!
For the moment I am deep in a project and need that printer every day.
I`ll send the printer only to Formlabs when there is definitely a solution for that problem.


I’ve also read all the threads and tried all suggestions. The plastic part to press the cartridge in a tighter position worked for three or four prints then it started to show the error message again.
I’ll be back with the measurements and see if there is anything I can do to make it working for all cartridges.

Since december 2017 I use to have constant “cartridge removed”, “missing tank”, “unknown consumable”… I get in touch with support and tried all options, even cartridge floor replaced… Nothing works. But when I installed the first LT tank all errors gone. No idea why, maybe because LT tanks fits more tight and block all vibrations?

I’m back with the measurements of the cartridge and they are very close. Maximum difference is 0.1mm. So I don’t really know what to do.
What I tried though is, to move the tank manually to see if the error occurs, and it does!
Unfortunately I also got a new message: “Tank removed” and immediately “Tank inserted” while moving :confused: I’ve never had this before …

1 Like

Had exactly the same issues, swapped the cartridge floor, where the contact is made with the machine, tried packing out the tank with tape, tried shoving a bread knife down the side of the tank, and a bunch of other things. Nothing worked. Ended up sending the machine back to Hungary for repair, which worked and I haven’t had that problem since, however they swapped my big orange cover and the frame it is fixed to with someone else’s dirty cover; mine was pristine, and only a few months old. I suggest if if you do return your machine, mark every component you can with the name of your machine, in indelible marker pen…

Some of the my recent cartridges have had some moulding flash around the bottom edges. These threw the missing cartridge error, especially when the cartridge was nearly empty.

Removing the flash by scraping the edges of the cartridge with a sharp knife seems to have cured the problem.

1 Like

Thank’s Bill and Emilio!
I’ll try the LT tank and will also check the cartridge bottom edges.

1 Like

Exact same problem here with 2 replacement printers. Tried everything, including replacement cartridge floor assembly. Current printer is being repaired by FormLabs directly (Which I haven’t done yet). So hopefully they’ve resolved this issue. I suspect it was either a large batch of bad resin cartridges or it’s a design flaw with every single Form 2.

@goddard11: That doesn’t sound so good because I want to send ours in, hoping the local service will find the problem. They might not…

Yesterday I’ve tried the Flexible V2 again and after some error messages I put more and more tape on the bottom sides until the cartridge was really tight fit and the message didn’t show up for two layers. But after that it stopped competely with “Unknown Consumable removed” :neutral_face:

I also took just the cartridge floor (the one I removed for replacement) and wanted to see how a cartridge fits in there and how the chip is placed in relation to the sensor pins. Actually the design is not too bad. There is not really a lot of movement and the pins are perfectly touching the chip. That makes me wonder why it happens only when moving the tank and not when shaking the whole printer a bit.

Anyways, the next three things I will try:

  1. I will use a new Clear V4 cartridge, prove that the error shows up and then use an empty Clear V2 cartridge (with a V4 chip glued on and some material inside) and test it again. Then the difference is really just the cartridge body.
  2. Open the printer and see if the cables of the replaced cartridge floor are all connected well
  3. Loosen the cartridge floor trying to tighten it in a slightly different position if the tolerance allow it, if not putting some tape on one side and fixing it this way.

I’ll report the results as soon as I know more.

If anyone as another idea, let me know. I really want this problem fixed.

Alright this is what I’ve done and the result:

  1. I used the Clear V2 cartridge that came with the printer with which I haven’t had any problems and tried to print a simple cube. The error message “Unknown Consumable Removed” showed up and the “Cartridge Removed/Inserted” error as well. I didn’t watch the whole printing process but since it was only a 1h job it printed it completely but now with the errors.

  2. I opened the printer again and checked every cable and removed and installed the cartridge floor again.
    After I removed it I ckecked how the Flexible V2 cartridge fit into the cartridge floor and how the chip is aligned to the sensor pins. From what I could see they are always touching the chip completely and there is no way of having no contact. The only concern I have is that one pin could touch both contacts on the chip, because it was very close, but I could see it clearly. But with removing an inserting the cartridge I would expect that it might only happen once in a while not constantly.

  3. I haven’t tried to position the cartridge floor in a different way, since the result of (2.)

Result: Even with the old cartridges I now get the same error, which means it’s not the cartridge. And the positioning is totally fine in my opinion.

I still get the error message “Tank Removed/Inserted” and “Cartridge Removed/Inserted” when moving the tank or pushing it down (against the springs).

I really think now it’s a loose contact or similar. But I will leave that to the service finding it.

1 Like

I watchedd my machine when it was having these problems and it always seemed to flag up after the resin tray had moved sideways a few millimetres. I reckon its an overload voltage drop caused by the sensing system reacting to the drop in voltage caused by the tray motor running at maximum torque…

I could be wrong though!!


Interesting thought!
What makes me wonder is, that it also happens when I push down the tank against the springs. Then there’s no movement at all. That’s why I thought it’s more kind of a loose contact.

1 Like

I called in for this problem 2 days ago. I was told I could send it in for repair ($800) or I could just switch and print in Open Mode. I was recommended by FormLabs to print in Open Mode for now as it removes the error completely and that they were working on a Firmware fix for this as quickly as possible.

I have exactly the same issue, was told by support to send machine back to have cartridge floor replaced, hesitate to do so as I hear this does not fix the problem, someone mentioned the LT tank will solve this, has anyone tried yet?

i use to have “missing tank” Error.
i changed to the LT tank and now i keep on getting “Missing Cartridge Error”
or “paused because the tank and cartridge are using different materials” Error.
I recommend to do just as FormLabs recommended to print in Open Mode for now as it removes the error completely,
i tried it and it works.

I swapped the cartridge floor and it did not correct the issue on mine.

I’m printing in open mode too, of course it would work, but FL should find a solution to fix this, otherwise we are like using Formlabs 1?