PreForm taking forever to start up Windows 10 Professional - Again


#1

Hi Community, this exact thing has been asked at least twice before but with no responses other than people saying they too had the issue, and nothing from Formlabs

I’m using a new HP Mobile workstation, 8 Core i9, SSD that reads at well over 1Gb/s
KeyShot8 opens in about 3 seconds
SolidWorks Premium in 25 seconds
PhotoShop 10 seconds

Formlabs, well, I started it about 10 minutes ago and the blue wheel of Windows 10 death is still revolving

OS is Windows 10 Professional and Preform takes forever to open up.
We tried to solve this issue without success.
It seems to get slower after it’s been opened a couple of times, I did a first install yesterday morning, it took well over a minute to open, then when it was opening super-slowly a re-install yesterday afternoon, it loaded a bit quicker, about 2 mins.

Today its still not loaded, that’s 12 minutes now…

Uninstalling, reinstalling and then registering myself back to FormLabs and each of three Form 2s each time I want to use the software is a workaround, butr clearly very far from optimal.

Is this a Formlabs issue? Is it because its still only a 32bit application?

Thanks for any clues.

Stephen


#2

Well, I think I’ve solved it, or for the moment it is working anyhow, but very strange solution as follows:

When you downnload PreForm, it tells you the System Requirements including:
Windows 7 (64-bit) and up

There’s even a big blue banner next to the download link that says 64bit, but then the PreForm installer by default puts it in the C:\Program Files (x86) i.e. 32bit folder, and as it installs the task manager says it’s a 32 bit program.

Is PreForm for Windows 32bit, if so, why all the 64 bit minimum requirement blurb?

Given it had put it there on the two previous installs with disasterous outcome, I thought, I wonder what happens if I point the installer to the 64 bit folder even though PrForm seems to be a 32 bit app.

It installed hapily and now seems to open in about 15 seconds as it should. Have tried quitting, re-opening several times with different files, and it no longer hangs.

So, I hope this (seeming) fix is of use to others.

Install it in the wrong folder, C:\Program Files, and it works!


#3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.