Preform 2.17 STL import issues


ever since the update to 2.17 i cant get preform to load my STL files. The 2.16 version works fine.
I was looking for solutions in the forum…

after dragging a STL file into the software it always prompts to repair the part.
if i ignore nothing happens, if i click on repair nothing happens

i have tried uninstalling and reinstalling: did not reslove the issue
a downgrade to 2.16 is not pissible as the printer is running the most current firmware.

any ideas what is causing this


Does the same thing happen when you click File > Open… ?

maybe your file is too poly heavy. I know when I used to want to open a very heavy file with 2 million polygons it would not open.

but since the update and preform is now 64 bit I can open models that are around 5 million polygons.

thanks for the replys

@ Craig
same thing,

the Poly count is very low around 70k

it just seems as if with the last update something changed.
my usual workflow was SolidWorks -> export STL (as ascii) -> open in preform

sometimes, on older preform versions it would ask me to repair
now its not doing anything if i click on repair

I also have the same problem with 2.17

Same problem here…

I can’t import old stl files, that worked well in the past.

Have you submitted a ticket? Since PreForm works across so many computers, there may be some instances of failures that we are not yet aware of.

Hi Craig,

not yet, was hoping to find a solution on the forum.
I shall do this today.

thanks for the help

at All,

i issued a service request (#161127) the Formlabs team was very fast in reacting. Thanks for that!!!

the issue seems to be related to non standard letters or signs in Folder Path and / or filename
in my case i had a " ä " in the foldername where i save all the STL files. hence the issue on all files.
(this is the only thing i did not check :wink: )

the workaround for know: revert to standard (english) letters for Folders and Filenames.
After the *.form file is saved you can push it to where you want. this is then not an issue any more

assuming Formlabs IT will work on this and provide a update to preform


I had similar symptoms on earlier versions of Preform, and opened a ticket with Support (#146256) including a sample file (which did not have any special characters in the name). Unfortunately it’s intermittent and whoever worked the ticket wasn’t able to reproduce the problem. It’s possible they didn’t open the file enough times, or it really was something specific to my (or our) computers. One suggestion they gave me, for what it’s worth, was to update graphics drivers.

It did seem to occur more frequently on files with larger polygon counts. And only after dragging in at least one file that needed repair.

The way I work around it is to close Preform completely, then open the file. I’ve never had any problem as long as the file is the first one opened (via the File | Open menu, dragging and dropping, or simply double-clicking the STL file) after starting Preform from scratch.

I suspect there may be some internal state-related bug or leak in the Preform code responsible for STL file handoff to the netfabb engine (or whatever they use) for analysis and repair.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.