Need help for open stl fiel issue


I have been facing issue such as,
Everytime I try to open STL file, Preform has allways failed to open it. So, I have never pinted anything but the buttrefly
as a test shot.
“LOAD FILE ERROR - Unable to read this file” message poped up in each and every attempt I made.
It is sure that all the STL data I stored in PC has no defect.
I could not figure out what could be the souce of the trouble.
Is there any possibility of compatibility problem between Preform and Windows 8?

Any tips would be appreciated, so please help!!

Takehiro Nakano
Form 1 owner in Japan

Have you tried using obj files instead? I would also re-install preform and check firmware on the printer.

Have you tried any other models? PreForm should work fine in Windows 8.

I really appreciate you guys responging my call!
I down loaded several other model, but result are allways the same.
Preform has failed opening the file all the time.
Now I am stucked in the middle of nowhere…
I will keep in touch with you guys and seek the way to get out of this kind of trouble.

Thanks a lot anyway!!


Takehiro, good evening!

Could you tell me, what is your current status with your problem “Unable to read this STL file”?
Did you find out the reason of it??
I have totally the same problem.
I exporting STL from AutoCAD Mechanical 2014.
STL successfully checked for holes and etc with MeshLabs Viewer.
I have Windows 7 64-bit Professional.
After reinstalling PreForm v.1.8.1. I can not open that STL files that I successfully opened with the previous version of Preform.
My models are very simple. Just extrusioned area.
Kind regards,

Hello @Georgy_Tavrizov — are you receiving any error message? Can you share your models with us? I can pass them on to our software team to check out. Additionally, I would make sure that you have the latest graphics drivers installed.

Hello, Sam_Jacoby!

Trying to open in the program PreForm version 1.7.1 or 1.8.1. file “Example_20150118_2036.stl” I recieved the “load file error” with the message “Unable to read this file”.

Your colleague successfully opened my STL file in PreForm.

check the e-mail from to at January 20 2014 with the topic Re: [Formlabs] Re: Using Form 1+ with Uninterruptible Power Supply (UPS).
There is attached the very simple STL model, that was automatically exported from AutoCAD 2014 Mechanical.

I think, that the problem is focused with libraries, drivers and etc, that PreForm STL-importing subprocedure uses.

All updates installed on my notebook.

Thanks in advance.
Kind regards,

This sounds an awful lot like an encoding/locale problem. Have you tried switching your locale to English/UK or English/US just to exclude that possibility?

I might be completely off on this, but it might be worth a shot.

Hello, to all!

I just now found out the source of my issue!

My STL-file was located in the path that contains cyrillic symbols.

This is the only reason of the error “load file error” with the message “Unable to read this file”.

STL file name and the path to the STL-file have to contain only english symbols.
Because Preform import subprocedure can not open STL-file, that has cyrillic symbols in the path and\or in the file name.

So, if you want to check this issue, imho, you should to use unicode.

Great thanks and respect and kind regards to Ante_Vukorepa! :slight_smile:

Kind regards,

1 Like

Nice, @Georgy_Tavrizov. Thanks for the tip, @Ante_Vukorepa.

1 Like