Power help please!


#1

I know the 1+ is no longer supported, but I am hoping the users can help me.

I bought a 1+ that was confirmed to work. Now ingest it home and the power will not come on. I had to buy a power supply for it. I have a 24v 2.5amp and a 24v 5amp. Both 5.5 od and 2.5 id. When i plug it in using either power supply, the power button blinks once as I plug it in then it doesn’t work.

Could the mother board have gone bad? I have a spare motherboard for it.

Any suggestions are welcome. Help!


#2

Check and make sure the SD card is properly inserted in the slot. It contains the firmware and boot strap. Without it it wont work.


#3

Thanks! Unfortunately, it was seated fine. I even took the sd card out and tried putting it back in. I went further and pulled the sd card out of the other board I have -which looks to have a component so there goes my spare - and tried using that. Still no luck.
I have noticed a slight buzz when I plug it in that seems to occur at the moment the light around the button flashes. Is there any trouble shooting guide anyone is aware for power issues?
Or, any other suggestions from anyone?
Truly disappointed that I can’t even get the power on!


#4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.


#5

#6

Have you got any progress on it? The thread was recently unlocked from an auto-lock and enquiring minds would love to know :wink:

I’m wondering if that power supply might be junk. My Form 1+ came without a power supply, and I happened to have a “universal” laptop power supply hanging around that happened to max out at 24V, so I switched it to 24V and have been using that without issues. Most similar to mine is this one: https://www.ebay.com/itm/303364461629 - not the exact site I bought it from, but all the markings and design is the same in the photos.


#7

Hello.
Does anyone have the solution for this no power issue where the button flashes once and then nothing? I am getting voltage out of the factory cord but… Any help or direction to start would be appreciated.