More issues with PreForm

Started to create a build of multiple parts on the build plate. On opening the STL file PF says it needs repair so I say OK. With that it plugged the drain holes. Went back to SketchUP 2017 and imported the STL file which showed all kinds of errors? I then talked with a friend who also does 3D designs for me and he sent me a photo of the part in MeshLab which showed no errors.

So, I started over opened the same STL file and told PF to skip the repair and sure enough the piece was perfect, no errors.???

With that I will double check any STL files coming into PF by reopening and not having the STL repaired to see if that does the same thing again.

i get broken file warning all the time over files I know to be perfect.
tech support says its related to file size… apparently, preform can only handle about 300mb of geometry, total- per build volume. In my case, any file that bumped the build near or over 300 was rejected as “broken”- regardless of whether I tell it to repair- or ignore- NOTHING gets imported.

Check for this weird behavior- if I get the file broken alert… try saving the PF file… then quitting PF entirely, and then relaunching PF from the SAVED FILE’S DESKTOP ICON.

suddenly, the same file PF claimed was ‘broken’ imports without issue.

I do too, broken file warnings a lot. I will first ignore them and check to see how good the piece is in PreForm before letting it repair. Yes, my items, even the smallest, are quite complicated designs and will get even more so as I add new products to our line.

Thanks for the info.

i was wondering why my models were all broken. Rhino usually corrects issues but i noticed that the new PF sees broken models all the time now.

It’s an out-of-memory issue, alright.

The Windows version is still 32-bit, and i’m willing to bet the amount of RAM it can address being limited is the cause. Same issue doesn’t occur on Mac version (which is 64-bit, of course).

Here’s the thing - i’ve got huge files (scans of some archeological artifact castings, the rough stone texture had to be preserved in the printed repros, so i didn’t decimate much) that will load fine on first attempt. If i remove the object and load again, it will report the model needs repair and attempt to ”repair” it (and fail). If i repeat it the third time, it fails immediately, as soon as the progress bar starts filling up and doesn’t even load.

Restarting PreForm ”resets” this, so first one works again, second repairs, third and subsequent ones fail.
Which indicates there’s a memory leak in newer PreForm versions as well.

I’ve had an open ticket about this for a while now, support’s aware, and i occasionally (when PreForm updates) poke the ticket and they re-poke the engineers in turn. Hopefully we get a memory-leak free PreForm and/or a 64-bit Windows PreForm at some point.

Sounds like you need to get a more robust computer if you’'re going to be doing such large files.

I had a similar issue with my laser cutter not excepting certain files that use the “vector sorting” to optimize the cutting. Before it would hang the entire machine and I’d have to shut down and restart . I upgraded to 256 GB of RAM and all was solved.

Problem we had with the Preform Repair wasn’t memory related. It’s the Preform that has the issue.

You misread what i wrote. Reread it without glossing over the key bits, please.

I’ve got 64 GB of RAM.
The same files open fine on a Mac with 16 GB.

It has nothing to do with “getting a more robust computer”, PreForm can’t address more than 4 gigs, because it’s a 32-bit binary (on Windows). On top of that, it doesn’t deallocate the memory completely when removing an object, which is why it works for you when you close and reopen the .form again.

1 Like

Sorry on that. I’m having more questions about PreForm in that I have a part that I was printing solid but that used too much resin so I hollowed the part. PF is now telling me that the hollow pieces use more resin than the solid ones???

I ran some solid and I’m now running some hollow. I’ll measure 4 of each against each other but expect the hollow to the the lighter by half at least. That then raised a big question on PreForm’s ability to calculate how much resin is actually being used.

I rely on the PreForm calculation of resin used to come up with the price of a product and this issue puts that all in question.

1 Like

That sounds like a serious bug.
Gonna do a check with a hollow and solid object too and see what happens.

Just tried that, PreForm definitely reports less resin used for hollow, and the amount seems about right.
Try it before adding supports - if your objects are very small, the volume of resin used on supports might actually outweigh the resin required to fill out the object.

I printed 4 of the hollow pieces and they were solid. This is strange as when they were in preform I did a close up and scan around through one vent hole and I could see the open vent hole at the bottom.

Still, if they were going to be solid they should have used the same amount of resin as the ones I knew were solid! But according to Preform they used 50% more resin???

My guess is, either the original geometry was mangled, or PreForm mangled it.
Self-intersecting, non-manifold geometries can really screw up things like measuring volume.

It’d make sense for a messed up mesh to both, end up as solid (even though it was supposed to be hollow), and measure as greater volume than it should be.

When you’re in PreForm and use the slicer, do you see the hollow interior? My guess is that PreForm “healed” the hollow out of existence. The mesh repair makes some guesses about what’s inside & what’s outside. If the hollowing shell had backwards orientation, then it might have guessed incorrectly.

What tool did you use to do the hollowing?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.