I guess I'm one of the lucky ones. RESIN SENSOR ERROR!

I told myself, stop tinkering on crude machines ang go buy a FORM 2 so I could move on and concentrate working on my designs. so $4000 later, I guess I was wrong. very wrong. FORM 2 is less than a week old.

By the way I already tried different things, all of today i tried re-inserting, twisting counter clockwise, cleaning contacts, removing resin. I haven’t tried re torquing the sensor screws, I don’t have the proper tool, the machine never came with one.

Since it’s a sunday, all I could do is leave a message to formlabs support and sourcegraphics where I bought it from. So here’s to a start of a brand new adventure.

Day 1:
Tried a brand new resin tank, and new resin black v3. Nothing, It just says “RESIN SENSOR ERROR”. Not even a drop of resin went to the tank.

Day 2:
Got in touch with Support. gave instructions to reseat the ground screws of the resin sensor. Ordered the 1.3mm hex key tool required for the procedure.

Day 3:
1.3mm Hex Key came in the mail. Measured with caliper it says around 1.3 ~ 1.35mm. Tried it but it’s weird that the fit is loose for the actual ground screws. No joy. Need to order another one.

Don’t worry, you are not alone!
I had 2 printers with cartridge and resin sensor errors… That’s what the PSP is, the only option in those situations when you have tight deadlines…
It’s an amazing equipment, when it works. Unfortunately, reliability isn’t the strongest attribute of the F2.



This happened to me one time and I luckily found the culprit pretty quickly. I cleaned the resin sensor and the side of the tank and it resolved my problem. What I did was use a cotton swab soaked in 99% isopropyl alcohol and cleaned the sensor twice and then the third time I did it with a dry cotton swab to remove any residue left from the alcohol… Use this advice at your own risk as I’m not sure what the procedure is for cleaning it. I would definitely open up a support ticket and see what they have to say.


1 Like

Thank you for the responses. I’m at their mercy at this point. I tried submitting a ticket but nothing shows up on my activity list. maybe a formlabs representative can see this and help me get in touch with support.

Finally got hold of customer support via live chat and created the ticket for me… They asked me to reseat the grounding screws for the resin level sensors. I ordered a 1.3mm HEX key thanks to Amazon and same-day shipping. Hoping for the best and will update soon.

The 1.3mm hex key came, even measured it with a caliper but it seems loose for the actual ground screw. I attempted to loosen the screw but it is so tight that the hex key just grinds to the next notch. I’m afraid if I try to force it, it will strip the head. I tried the next size but that didn’t fit obviously. So I guess I have to buy multiple 1.3mm hex keys to find a good match. Asked formlabs if they could recommend one for purchase. No response yet.

Sounds like a .050 inch hex key is what you need since the 1.3mm is a little too big.


1 Like

Hi Chris, it’s actually smaller for the screws in my printer. the fit is loose to make a firm grip.

Then I would try a 1/16 inch and see if it works.


1 Like

Yes I did, bought a set. That one didn’t fit at all. So I guess I have to buy another brand.

Would you be able to take a picture of the screw head with the calipers across the hex width?


1 Like

yes, i’ll post a photo when I get home.

Hi friends,
I have got the same problem with new printer before first print. button was succesfull but only for one print. Now I am discussing with support and after few days I received an advise to reset the device and/or fix screws showed on image. Very carefully. If they are already fixed - loose a little and fix again. It seems like a magic. I will inform you about results beznazwy

1 Like

Thank you picker. I got another hex tool coming in tomorrow to test out. Hopefully this is the one. I’m glad your issues are resolved. I hope the same for mine.

I have no key this size at home so I only checked with another, that screws are not open or loose - as service suggested. Service also recommend to make factory reset (remove power cable and connect again with front control button depressed for few seconds). I performed this and it seems that I got success - 2 prints completed. 3rd one stopped after 3 layers with the same. Conclusion - problem still exist.

Hi Picker,

I think you need to clean this area too (red circle). As far as I know that whole thing is the sensor. So any residue or dirt in that surface will cause the issue.


Thanks for tip. I will try
My printer was new. Just opened. and first print has failed at the beginning.

I’m on my second unit I got through about 4 prints and now I’m back in same boat. Awaiting my parts to arrive I can take it apart and replace the bed motor. I’ve tried the electrical tape near the sensor and setting something the cartridge to no avail.

Mine worked after awhile but had other major issues, I just sent it back today. Hoping for the best. Formlabs Customer Service is the best in the planet.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.