Formlabs Website Store Support

I am receiving an error when I try to update the Wash/Cure Firmware

I am getting the following error when I try to update the Firmware for the Wash or the Cure.

“Error while dropping to boot loader.”

I get the same. While in that error message, just unplug the cable on wash/cure and plug it in again! For me this trick works all the time.

:open_mouth::rofl::face_with_raised_eyebrow:
Thanks! I’ll try that.

I think there may be a timing issue watching for USB device changes - I found the only reliable way to get it to work on my (Windows) machine is…

Start update process
When wash/cure display blanks (it has changed to DFU (boot loader) mode), and updating is NOT being performed - ie. 20 seconds and nothing happening on the updater window
Unplug power from wash/cure unit
Hold front button down and reinsert power, for me the updating process starts

Then I found the update process wouldn’t finish properly after changing back from boot loader to normal mode, so a quick unplug and re-plug of the USB cable (not power) does it.

I think I tried just the disconnecting the reconnecting the USB on its own the first time but didn’t do anything - maybe I didn’t and that would have been enough, try that first!

I remember there used to be a problem with USB ports and sleep / power management timeouts in windows …we used to have to turn off the “let windows put your device to sleep” function in device manager hub/power management tab for each hub

I should have mentioned that I was running the updater on my Mac. I’m not sure if that make a difference in the process.

I will not be able to try again till Monday.

sorry im an idiot …just scrolled all the way up saw your mac screenshot…one thing i can think of if you have a new TB port mac is swap your port or dongle… i have had devices not like the combo video/usb/power dongles but did like the “usb only” ones and vice-versa… and other times liked one port over another…shrug…also can try with a powered hub or not… sometimes matters ,… some devices hate going though hubs.

:laughing: Not at all! The interface cues are easy to miss.
I have the new M1 Max MBP. It only has USB-C for I/O, so I was using a Belkin powered hub for USB-A, but it was not powered up, since I use it for my mouse, and it works fine like that. I will try it powered up next time.
Thanks!

Did you have any luck?