How to unsubscribe from emails?

Hi all,

I love coming to the site to read the forum, but I don’t want to have notifications coming to my inbox. I have gone to my preferences and un-checked everything that looked relevant, but I still get emailed thread posts.

What am I missing?



Looks like there is an unsubscribe option in the actiual e-mail that you can go to.

Yep, but that just brings you to the preferences page, where I have everything un-checked.


Well that doesnt make much sense… Im curious about this as well, Let me know if you figure it out.

Declan, I checked your account settings and see the same: everything un-checked. Is it possible that you’re getting notifications to a different email address from your forum account? Feel free to forward one of the recent thread updates to, and we’ll be happy to take a look at where the emails are generated from.

1 Like

No, it is very seriously broken.

I also have all of the notifications turned off, and am getting flooded with them.

That is a possibility (at least for me). My phone is logged in as username Declan_Halpi564, which is associated with my work email. I unchecked everything there, too, so we’ll see if that does it.


You’re welcome, Declan. From the replies in this thread, it looks like you have two accounts: @Declan_Halpin and @Declan_Halpi164. Let us know if we can help merge this.

So sorry to hear that you’re also having trouble, @liqdfire. Could you please forward a copy of a notification email that you’ve received so that we can look into this more closely?

Where would you like me to forward them to?

We usually prefer to gather information in our webform.

In this case, since you already have an email sent from Formlabs, could you please forward one of the notification emails to and share a quick summary of the problem (e.g. “I’m receiving notifications from the forums, even though I’ve changed my settings to opt out.” so that our team can help you out?

If you have any issues with erroneous email notifications on the forums, as the comments above mention, please feel free to forward the emails in question to support. We’ll be glad to look into your settings and reduce the email volume.

Just a followup - my problem is solved. It was the result of 2 emails being registered…



1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.