Hollow/Shell STL file methods?

SolidWorks wont import STLs as solid bodies so I cant shell them with it.

I have watched every video I could find of how to shell with ZBrush but I still cant get it to work.

I don’t have the Pro version of NetFab so that’s out.

I noticed in the video for the Solidator that hollowing models was included in their software so maybe there is something like that somewhere that I could use if it would let you save back to an STL again.

I’d really like to figure it out with ZBrush if anyone could help ,but if anyone has some simpler method(s) that they could share?

Thanks, Vince

Hi Vince,

I bought NetFab Pro, and from memory it’s shelling function was not great, I think it made inner walls that intersected the outer wall at thin sections. I do have access to Geomagic Studio (it’s not mine) and that shells perfectly (and does awesome auto surfacing as well) - it’s obviously hugely expensive (out of my league), but I think they have a 30 day trial version - which might help you for a bit …


Thanks Kevin I’ll look into that. I would love it if they could just add this function into PreForm!

From the videos it looks like ZBrush does a good job its just so complicated and none of the videos make any sense.

At the risk of sounding ridiculous (regarding my lack of experience…), have you tried to hollow the object using the Blender ‘boolean’ operator? I can imagine making shapes/meshes that would be used to hollow out your objects. Put them inside your model and use the boolean modifier with the ‘Difference’ operator.

Hope this may help.

I think I did try Blender once a long time ago and I remember I didn’t like it but if I cant find some other way I’ll try it again! I just installed that Geomagic Studio that Kevin suggested but I havent found how to shell with it yet, but it did have an easy way of deleting little floating parts from scans. Hope to figure this out though, it would save a ton of resin, which would be great as resin = $

In the meanwhile if anyone could shell this model out for me I’d sure appreciate it


Here you go Vince,

I use Geomagic Studio 2013, so the interface has probably changed - but I’ve included a couple of screenshots. The second one is misleading because it’s the shelling dialogue, but the part has already been shelled.

You didn’t specify wall thickness so I went with the default suggested by Geomagic of 13mm - assuming the part is in mm?




Thanks Kevin, I dont understand, I’m using the exact program but don’t have that feature showing, here’s a screenshot. Command search didn’t find shell either.

bugger, well unfortunately I’m no Geomagic expert, and I don’t understand either. Perhaps an email to their support? In the meantime of course you have the shelled part I already uploaded. Is that 13.7mm wall ok for you?

yeah, I just installed the preform update and will give it a try, thanks! I may try reinstalling Geo, I’ve been transferring several large files around so maybe something got messed up with all my multi-tasking goin on…

this bugged me. I did notice you have some different options in your command ribbon, an extra Polygons tab, and also Points and CAD tabs. So I had a look at the Customise panel available from the quick access menu in the top left - and lo and behold you can customise what appears in your command ribbon.

Noticing that the CAD tab had a “modify resolution” command - I tried the command search for that and got no result, so I created a new tab and a new group and added that command to - then command search shows it.

So perhaps you just need to add it to your command ribbon? Geomagic Studio is weird - in some ways it’s fantastically easy to use and in others is so obtuse I lost tufts of hair when first trying to use it.

Awesome I got the shell function now! I don’t know how you get the section view to see inside yet, but I’m certainly glad to have the ability to hollow out STLs! I’ll get the rest as I mess around with it, but I really appreciate the help!!! This should save alot of resin! I have had a couple things I printed with hollow cavities hold some uncured resin inside, so it will be interesting to see if this traps any. And I’ll have to mess around with various thicknesses to see how it appears in the models. I frikn love 3D printing! Thanks again guys!

Hey Vince - section view is in the display tab in left panel “view clipping” - it automatically orients at normal to the direction of the camera on to the part. Very glad you’re up and running ! :slight_smile:

Now of course the pain will come in 30 days - and you ask Geo how much their software costs … :frowning:

As for trapped resin - if your part is a perfect shell - then yes certainly it will trap resin, and you wont see the benefit of reduced surface area and suction grip when peeling (which is the main reason I wanted to shell parts).

So you’ll need to add through holes. Lots of ways you can do that - Netfab does it (although not sure if that’s pro only feature) you can also make holes in Geo, but I haven’t figured out yet how to make them “through” holes with a connecting cylinder.

Yeah figuring out how to add holes is next, all of this would be so simple if only SolidWorks would load STLs as solid bodies! I keep looking for anywhere close with ZBrush classes too, I’m just not one for learning online.

I did one print of the hydrant that failed, an unsuported bolt caused the failure. PreForm didn’t show any red areas though. But anyway I tried it again, haven’t removed supports yet but it looks pretty good, it didn’t trap any resin and is air tight (floats in the alcohol bath)! I scaled it down so the chains are really really thin, its going to be a challenge keeping them intact!

Nice one Vince, looks cool. Don’t envy you the task of freeing those chains though :slight_smile:

Figured I’d share the results of my first hollowed model here, and yeah Kevin the chains were no simple task!

It’s 8.5cm tall and all of our hydrants here are yellow incase anyone wondered why yellow.

I’m unfortunately having some major printer issues now and waiting to here back on a support ticket.

Hey Vince,

Can you describe the issues you’re having? not so I can help (although I will if I can) but because I want to collect a catalogue of the things that go wrong with the Form1 and document a diagnosis script, all really valuable stuff for the wiki …



Sure, I’ll just start a new post, I’ll call it “skewed after firmware update”

Autodesk Fusion 360 can import a mesh and convert it to a BREP Solid. The enthusiast license is free to use as long as you are not using it for commercial purposes.