Formlabs Form 2 Resin Sensor Error

Hey everyone,

I have a Formlabs Form 2 that isn’t printing properly.
Basically, when I start a print, the resin tank begins to heat to ~30C, but no resin flows and then eventually I get a repeating error:

The printer prints fine in open mode, but I’d rather not lose all of the features.

From what I can tell, the servo to swing the small arm and pinch the release valve doesn’t swing (I never hear anything and if I remove the cartridge it’s still in the original position). But I’m not sure if it’s even supposed to do that, or if it’s an error with the sensor board itself that precludes the error.

I’ve already done the following:
-Removed the motor and cartridge board and cleaned off all resin
-Removed the resin sensor board and cleaned off all resin
-Retightened all screws on the motor board and ground screws on the sensor board
-Tested the servo and gearbox assembly with a variable-voltage generator - it works fine

Formlabs quoted us >$800 for a repair or straight swap (and that was before I disassembled it to test if it was fixable), which isn’t really worth it since we already have many other machines. This is more of a test project to see if I can salvage this thing, but if not we probably aren’t going to go to Formlabs and probably just use open mode…

My next test steps are to:
-Hook up the servo to a manual voltage source to override the machine’s activation of the servo and see if it prints okay
-Hook up a volt meter to the motor activation pins to test if the motor is getting a voltage at any point in the tank filling

There were/are a few other issues, namely that the cartridges weren’t detected because the pins on the servo board were bent (fixed), and the resin tank screws isn’t perfectly calibrated as a result of disassembly, but it still prints acceptably in open mode pre-calibration.

This thing is seven years old per some stickers inside it dated 2015 so it’s definitely possible that something is just broken, it also sat broken for a long time. There was LOTS of solidified resin caked all over the internals, so I assume there was a spill some years ago.

If anyone has next steps, that’d be great. Unfortunately I don’t have a second Form 2 to test with. I have quite a bit of experience with FDM printers but I’m newer to SLA printers.

Hi ForgottenKing,

Sorry to hear about the repeated resin sensor error you are experiencing. You mentioned that you were quoted for a repair from us - was this a recent interaction? If this was not a recent interaction, I would go ahead and create a support case with our support team and get the latest logs to us along with what you have already tried, if there’s anything else they may be able to suggest on that end.

Hi, it was not a recent request, and also I managed to fix most of the issues we were having (cartridge not detected) are fixed, but it is no longer calibrated. I may get in contact with Formlabs to request a part, but I’m not sure if it’s the resin sensor board or something else.

It’s also possible I’m doing something wrong and the sensor is just dirty. Is there something I need to do to prepare or clean it? I just used isopropyl alcohol.


Hi ForgottenKing,

Cleaning the levelsense board (making sure to avoid the thermopile) with IPA is a quick step you can try, nothing special is needed there. In terms of calibration, if you have removed the tank carrier, replacing it would not help with calbration but we have seen some users work around it on their own.

Getting in contact with our support team will get you the best insight, as the logs can also reveal if there’s anything else that should be checked.

Hi, I’ll try it again. Just to confirm, the levelsense board is the ~5x2 rectangle behind the machine held in by 4 M1.3 screws? If so, I’ll clean it again, and if that doesn’t help I’ll contact support.

Hi ForgottenKing,

I’ll go ahead and link you to the page with the image to make sure we are on the same page - levelsense board.

Hope it helps!

Yes, that’s the part. It was covered in resin, but after cleaning it’s still not working. I’ll try and grab logs next time I’m in. Thanks.