Form Cure fails to reach 80°C


I am using grey pro resin and it required 80°C for 15 min for full cure. Unfortunately, the form cure just cannot go past 71°C. It fluctuates between 71 and 70. It is a brand new product. I opened it last week, used it twice so far. I checked the cover, it was properly closed and sealed. It is inside a cupboard so its not like there is a cold draft or anything.

Another thing is that I was unable to update the firmware. I connected it to my PC and opened the cure-wash updater, the form cure just keeps spinning slowly and the software stays on “preparing device to receive update…”, although I doubt the heating issue has anything to do with the update issue, but maybe I am wrong.

Hoping someone can help

First point : what’s your ambient temperature and how long have you waited ? It’s about 20 to 25°C where I have mine and going from 70 to 80°C takes an eternity, I guess it’s close to the limit of the machine’s heater for this volume… unless it’s voluntary to allow for the parts to fully heat-up.

Second point : I had this issue as well. Turns out the updater tries to get the firmware directly from Formlab’s server and it seemed unable to do so in my situation. I installed preform on a non-critical laptop and gave it internet access through my phone (wifi hotspot), which solved the problem.

1 Like

Hello, again John. And thanks for replying again.

The amb here is about 20-24°C. I waited about 15min, so perhaps I should wait an eternity as well. Thanks for the tip.

Figured out the firmware issue. I tried updating with a non-work laptop and it worked. Our work firewall was blocking/preventing the update.

Yeah 15min definitely doesn’t sound long enough. I don’t look at the Cure for a least an hour after launching a 80°/15min cure.

Glad you found a solution. Happy testing with Grey Pro, it’s a great resin to work with :wink:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.