Form 2 Resin Tank fill error

Due to a sensing error, the tank could not refill. Please reinsert the tank and try again.

This is the error.

I tried 3 new tanks , a used tank . I have tried this with white , tough and clear.

The tanks and the resin / cartridges are detected.

someone knows the errors and can help me?

i’m having the same error. Tried reseting to factory settings and clean all the connectors. No chance at all.


I’ve just set up my new form 2 and I’m getting the same error? Any response from Formlabs support?

I’m working in a room with a lot of strip lights so I’ve just covered the top of the printer with a piece of cardboard incase this was affecting the sensors. I didn’t think it would make any difference but that seems to have fixed it. Please let me know if that works for you.

I was getting the same error with the White material at first.

To fix it, I had to push the right side of the tank in all the way but not the left. Kind leave it turned slightly counter-clockwise.
Their support page briefly mentions this and it seems to work.


We are having the same problem, but all above suggestions don’t work. Any other idea?


I have sonsor now properly cleaned with “IPA”.

I must use the tank entirely correct. I push the tank on the right side until the end.
On the left I let the tank a little further forward.

I measure the right and the left with a caliper exactly. The difference is often only 0.5 mm if the sensor is working or not.

I will check if the fault is now always resolved.

Please excuse my bad english, I need to translate my text with Google.

1 Like

Same error here. I have just installed the printer and this error appears before the first print… nothing helps. Very infuriating. Some response from Formlabs support?!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.