Build platform is stuck during printing

Has anybody else experienced that the build platform won’t do the slow peel because the model is stuck?

I had this a couple of times already, just now I tried to print the rook model and that’s not big at all. The platform won’t move like it’s a huge model but it is not… It is getting really frustrating, are we only able to print tiny models or is there something wrong with my machine or silicone?

The silicone does not look foggy at all and I have new resin that I use.

It sounds like something is wrong with your machine. That is not expected behavior. It sounds like there are some issues with your peel motor mechanism, that controls the tilting of the resin tank. That’s something our support engineers will be able to diagnose for you, though. I would certainly open up a support ticket, by writing us at or using the web-form available at

This is happening to me too. It’s driving me crazy. This is the first “larger” part I’ve run on the form 1 since I’ve been using it. It seems almost like the build platform is creating a suction against the resin tank and not allowing it to move during the peel? It solidifies a sheet of resin larger than the build platform but very thin. It’s got me dead in the water until I can figure something out.

Alex — I’m not totally clear on what you’re describing, but you should certainly submit a ticket to our support team to get things hashed out. That “suction” effect can certainly take place, but it should not prevent the tank from peeling. That suggests that something else might be amiss.

I was wondering if this might happen. Recently, I had to remove the top cover (acrylic plus top of the metal frame) because of a stripped screw. With the top gone, I had a chance to shine a black-light on more of the machine and at angles that I could not have done otherwise. I found small bits of resin accumulating on the threaded rod. My build platform hasn’t stuck yet – it’s probably a good thing to keep it moving (i.e. frequent usage) so it doesn’t “freeze”. Just a possibility! This process could also cause the motors to work more – leading to a quicker demise.

This may be a bit different; the platform is stuck in the down position. I cancelled the print, but the platform can’t move to the up, parked position, but stays all the way down.

The motor tried to raise it, made struggling sounds, but not movement. The front panel displays a “ready to print” message.

I unplugged the machine, and it tried a “slow peel”. The platform is stuck to the bottom of the tank.

How do I unstick it, without damaging something? It was a print with about a 4" base.

1 Like

@Rob_Steinberg I had this problem as well. The larger the surface area that the part takes up on the build platform the more pressure it puts on the peel motor. After this happened a time or two support sent me a new peel motor which seemed to remedy the problem. It had gotten to a point where the tank would not come back to level center after each peel. Turns out, once I looked at the old peel motor, I noticed that sleeves that guide the worm drive shaft had given out. They’re just made of cheap plastic and the connection points to the motor housing had just given way. As far as removing it once it’s stuck, The only way I had any luck was to turn the machine back on. As it tried to raise the build platform I applied gentle pressure to help pull it up and keep the motor from binding.

This makes sense. I could hear the motor struggling during the previous couple of builds of large prints. If the bearing is just plastic, perhaps it’s under-engineered, and should be of sturdier stuff.

The platform isn’t going to release. After a couple of restarts, it became clear that the motor wasn’t up to the task.

I then manually turned the screw. That raised the tank and platform together, a few mm. But no release. When I let go of the screw, both returned to the original position, happily wedded for what appears to be all eternity.

I used considerable pressure, and stopped before I ruin something. I suspect all that’s to be done is to remove the screws from the top of the platform so I can raise it, leaving the rest of the platform behind.

Then throw away the resin tank, which will be ruined when I exert enough pressure to release the aluminum. I’m waiting for a response from support before I try that.

Yeah, since the build platform and the resin tray both slide out to the front you may very well be able to slide them out simultaneously. Once they’re out of the machine and not connected to the worm drive you won’t risk damaging anything.

As for the motor, yes, they’re weak. I found the part number on the motor and you can buy them for just a few dollars on the interwebz.

Curiouser and curiouser. Using my high tech skills, I applied “wait 36 hours” and tried the restart again. And magically, as from the dead, the platform has risen. Leaving behind a 2mm thick glob of resin on the platform, and only a bit of resin stuck to the tank.

The tank, which had only been used twice before, has a large cloud where the resin was, and bubbles between the two layers of the tank. Maybe the upward pressure I used to try and separate the platform from the tank succeeded in only separating the tank layers?

In case it matters, I filtered the resin (black) between uses, so there were no cured bits floating around.

As for the motor and sleeve; I’d gladly pay 10% more for some sturdier materials in the machine.

Off topic, I once had issues with the wires cabling the battery feed, which maintained the settings in a Boston Acoustics radio. They immediately broke off. They were crimped, not soldered, and the crimping was too energetic.

. I knew the guy in charge of support, and asked what the cost delta would have been to solder. Less than a penny. But the total cost of hw being around the order of 10% of the retail price, it all added up.

So, how many of the service issues we’re seeing could be cured with a $3,499 retail price? Or $3,749? Is there really so much price elasticity in the market for SLA printers? Inquiring minds…

I know I’d be ahead, just counting wasted resin and tanks, leaving out my time.

1 Like