Weird firmware compatibility issues - 1.5.15 & Preform 3.4.3


#1

First, PreForm 3.4.3 didn’t seem to know that firmware 5.15 had been released. I was able to manually fetch and install it ok, but now when I check for firmware updates, I get this screen.


#2

Reported and opened ticket Friday for this issue
they are working to fix it