Totally unhappy with my Form 2

I have recently gotten my Form 2, and have only had one successful print since I got it a month ago. I keep getting prints that fail and have even downloaded the resin combs within the forums (which I have seen others create without issue) and that also has failed. I have cleaned the resin tanks, bought a new one and installed fresh along with a new build platform, and new resin, and tried a bunch of different files with failures hitting me at every turn. Just curious if others have had these issues and what they might have done to fix this, as I am beyond frustrated. Please note that I am in talks with the support help, but so far not much success, and hoping that others might have found something. Also, the preform software goes to complete rubbish after installing for the first time and restarting…not sure if it has a massive memory leak but not happy about that as well. I have well beyond the necessary specs for the program and if anyone has a fix for that I would really appreciate it.


Can you post up some pics of your models, the orientation (Preform layout with supports) and results.

Without examples of the problems you are having it will be difficult to assist you.

Hey David, sorry I thought I attached one of the pictures. Hope this helps.



Fantastic models.

I would be frustrated if I just got a Form 2 and I got the results you are getting. I have a few questions.
For the Skull fail, Did FL suggest you nudge the build platform lower? It usually takes care of things like that. Did a second attempt net the same results?

For the zombies. I really don’t know where to start. They really came out poorly. Did you print it flat on the base? I would think the print would come out nicely. Did FL have any suggestions?

For the Head. How thick is the shell? Did you re-orient the model and try a second time?

I know I am not giving you much to work with. Sorry about that. Looking over your models, I don’t see a reason why you are having those kind of problems. Others have had issues with a clean optical path with the Form 2. Can you take a close look at the top glass and see if you can see any debris on the mirrors.

Has FL had you print the butterflies. Though I hate printing them, they are a good standard go to for troubleshooting. It may be worth printing out a set to be sure the printer can at least print something.

In PreForm, after you orient your model, flip through all the layers to look for any unsupported features. Look for an “island” that isn’t connected to anything else and is not supported. If you find any unsupported areas, add manual supports to them. If an area isn’t supported, it will likely cause cascading failures. This was the cause of failures for me.


This too was one of my issues early on. In fact I still have a screenshot of it:

In my case that middle part was not supported causing a failure.

1 Like

Hey David, no they did not suggest nudging the build platform lower and now quite sure how to do that. Are you talking about within the settings lowering the Z depth, as I kept everything at default and have not gotten into that area. On the zombies, I used the orientation button to have them set at a 45 degree angle as I have read that keeping it flat causes issues on printing. Though the print failed, and looked horrible:) As for the head I tried keeping to around 2mm thickness using the hollow function in mesh mixer, though I have had a few prints that were thinner and thicker due to the size, and have been figuring that out. I did nothing different from the previous heads attempt, other than having issues with the preform program…it just started acting super slow and buggy which I am still trying to see what the issue is on that. I have just uploaded the new version, and on the first open it flies with any object, but closing and reopening the program it goes to an super slow and sluggish movements using the same object. I have looked over the glass, and it was clear along with making sure the resin tank glass was clear and without any left over printing material based on the failures. I am now in the process of printing the butterfies, using the updated firmware, and updated preform program, with a new build platform and new resin tank. So I hope that it works and will show the results soon. Thanks for the response, as I appreciate any and all help on this!


Hey 3DTOPO, I will double check on if I have any unsupported features as I know I am trying some complicated objects. Though I downloaded the resin comb from Micheal, and the other from Jorgen and used exactly the setup they had within the form files, and still had complete failures. I am now trying the butterflies, to hopefully find out what the issues are.


That’s not typical from my experience–I’ve done about 200 prints and only had 1 failure which was due to me not stirring the resin before printing.


Zachary, I am happy that your form 2 is working as expected and would be willing to trade you mine for yours if you would like:) Haha, jk! I have stirred the resin and actually have gotten down in front of the form 2 and prayed for a successful print to no avail:/


1 Like

heh, my other advice I usually give family and friends (in jest of course) is to hit said item with an open palm. Hey…sometimes it works!

I would try adjusting the Z axis a mm or two again and try again. You can do this on the interface on the printer.

Here are the shots of the complete butterflies test print. Again, it was using a new build platform, a new resin tank and updated firmware and new preform program. The shots are the butterflies on the build platform, off the platform with supports, no supports, and close up.



If adjusting the Z-height didn’t do anything then customer service should be able to help out. There’s not a whole lot you can do yourself to fix issues that come up so they will have to take care of it.

Well those butterflies didn’t come out as they should (obviously). I think support will be the only ones that can assist. Hopefully they can get you printing without having to send the printer for service.

Hmmm, are you certain the laser window is perfectly clean? I once had failures from resin on the window that must have dripped from the build platform while the tank was removed (now I am certain to not remove the tray without removing the print platform). Dust will cause problems too.

If you need to clean the window, make sure to wear gloves and use PEC Pads (non-abrasive wipes). I start with PEC with some alcohol, then after I get it as clean as I can, I use a new micro-fiber cloth to get the last of the residue off (guess its residue from the 90% alcohol).

From all the issues I’ve seen and read about this does seem to look like a laser/mirror issue. I wonder if you could do a laser spot test or something? Check the glass above the mirror is crystal clear clean.

Hey Edward, I am not sure on how to do a laser/mirror test though I did make sure the mirror was clean. Support is suggesting that it might be a resin issue. So I emptied the resin tank, and installed a new resin cartridge and running the reprint of the butterflies again to see if that is the issue. I am crossing my fingers in hope that its this.


Spark, have you been working with FormLabs Help Desk? If your machine is new you should be able to get them to fix this.

Hey DigArt, yes I have been in talks with them and have done everything they have suggested. I just did yet another try with the test print butterflies with a completely new resin cartridge to no avail. Came out pretty much the same. Here is a link below to see how they came out. I really do not want to package back up my form 2 and send back so if anyone has something up their sleeve…please let me know!


link to 2nd attempt:

Kinda weird how all of the butterflies seem to fail all on the same side, in the same manor yet different locations on the platform.

sorry for the very crude drawings.