Texture Engine / Meshy not working

Hello,
I am trying out the Formlabs Texture Engine. When uploading a STL the preview looks great. However, when downloading the textured STL, the result is nothing like the preview and simply aweful. It looks like the exported STL has an extremely low resolution. Screenshots attached. I assume I am doing something wrong, but I don’t know what. Any ideas?

It looks like the max triangles slider is at the bottom, that will limit the amount of detail exported from the tool, have you tried increasing this?

Yes I tried increasing that value, but it doesn’t make a noticeable difference even when I put it all the way to max value.

Hi Lucas - this issue is driven by the way Meshy tries to do automated meshing to define the surfaces. It splits triangles at their longest edge until either the max number of triangles is reached or all edges are under some threshold length. This doesn’t always result in a very uniform triangulation.

I got around it by repairing / building a new mesh in Fusion 360, bringing that model into Meshy, then going back to Preform.

Thanks Nick, that sounds like it could be the reason! Could you explain a bit more detailed how you repair/renew the mesh in Fusion 360?

You start w/ the CAD file you downloaded, in my case an STL file of an iPhone case. Bring the STL into Fusion 360. Go to Mesh (top menu) → Repair. Then pick Rebuild and Preserve Sharp Edges. Then OK. This should give you a decent mesh with smooth surfaces instead of those large triangles you saw. Then export it from 360. Then proceed to pull it into Meshy, apply the surface finish, then back into Preform for prep for printing.

A lot of steps, but creates an amazing effect. Hopefully, one day it will be a bit more seamless.

1 Like