Printer says resin tank is missing?

I got my printer yesterday and set it up today. I followed all the steps but for some reason it says my resin tank is missing even though I attached it. I’ve taken it out and tried many times but it never changes. Does anyone know what the problem might be and how to fix it.

I’m fearing there is something wrong with my printer even though I just received it :frowning:

I am having this exact problem with my new printer - did you ever solve it?

Actually if anyone has this problem again in the future, here is my advice, as I just solved it, you need to use quite a bit of force when inserting the resin tank - it needs to snap in in place.

Had it happen once, just pulled it out and put it back in and it was fine.

Just got mah Form2 :smiley:

Same issue; won’t detect resin tank D: Don’t want to put cartridge in until I get a positive on that.

I’ve read a couple posts of people saying they had to add some solder-blobs to the resin-tank contacts to get it to actually hit the contacts :confused: How common is this resin-tank-missing nonsense? I don’t feel like jamming the resin tank in there any harder!


Nevermind… just had to shove harder heh. That’s one hell of a snap-fit.

It’s probably a bad chip in the cartridge.

Ask support for a replacement!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.