Print error code: 41

Trying to get a new Form 2 running as well. Computer and connectivity issues due to IT restrictions, so trying to use my personal laptop which seems to be working fine with the printer - connected via USB. Printer does not have a network connection so the upload diagnostics won’t be an option for me.

Same issue as others describe - just a start on the base structure before the print aborts with an Error 41. I also noticed that it takes nearly 2 minutes for each layer.

Has anyone found resolution that does not involve replacing the printer?

I think I was the first person on the forums to report incidents of Error 41. Since then Formlabs replaced my Form 2 with a brand new one and it has identical problems straight out of the gate (first print failed with that error).

I did have several successful prints on my first Form 2 before it happened, so I’m wondering if it might be due to a major bug introduced in one of the later firmware versions (and / or a correlated electronics issue).

Since BOTH of my Form 2’s have had this issue, I’m wondering just what percentage of Form 2 early adopters are being affected by this.

I wish Formlabs were more transparent about what “Error 41” actually means. If it helps, one of their support reps told me:

Error 41 is the software fuse for the galvanometers being tripped. This issue can be related to outdated firmware, but since you’re running the most recent version, we’ll need to bring your printer back for recalibration, since this problem will cause most of your prints to fail after a few layers.

Stephen, perhaps you could elaborate a little on what you guys know about this so far.

Thanks for jumping in and sharing your own experience with Error 41, Richard. I also had this thread open and am working on some summary information to share for anyone who sees Error 41. I’ll follow up with more details.

Great, looking forward to that. In the meantime, for others in the dark, Support shared a little more information with me:

The issue here is the reading from the galvanometer software fuse. If it detects current that is too high, it will shut down the print. Some versions of the firmware have a bug that calculates the current incorrectly, leading to false positives with the fuse. This only occurs on certain printers with certain calibration parameters, and unfortunately has happened to both the printers you’ve had.

I doubt they’d mind me sharing this, but since it was from a private conversation, I ask you don’t jump to conclusions (I’m not sure if your Error 41 is the same as mine) and please try to be patient with Formlabs.

Together with Formlabs support, I seem to have fixed my Error 41 problem after installing older firmware (rc-1.3.2-259) and an older Preform (2.2.1). This did not help, but reverting back to the latest firmware (1.4.3-288) and Preform (2.3.3) after the downgrade seems to have fixed it.

Maybe other people can also try this downgrade and update cycle to see if it helps. I received the older firmware after getting in touch with Support. My printer seems to be fine now. :slight_smile:

Really appreciate all of the reported issues, which are helpful for us to debug and get you answers and solutions. Here’s a bit more detail for anyone who sees an Error 41 message from the Form 2:

Error 41 indicates an error reading the galvanometers, based on the printer’s hardware and firmware version. To resolve an Error Code 41 message, update the Form 2’s firmware.

  1. Install the lastest version of PreForm.
  2. Check the changelog and download the latest firmware from Formlabs.
  3. Update the printer’s firmware. Instructions from formlabs.com/support.

Please contact our team with any further questions or reports of Error 41 messages on the Form 2. We’re working to correct this error in an upcoming update; it’s important to us that we can track these issues to fully resolve and prevent the error message for you.

[Edited 8 Aug 2016: removed direct links to older PreForm and firmware versions. At this time and for the past several releases, the latest versions of software and firmware are the recommended first steps to resolve Error 41.]

Thanks for the tip. I tried the downgrade / upgrade cycle; unfortunately it didn’t work for me.

I’ve got my Form 2 two weeks ago.
I did two prints with no issues, but after a few days I had the same problem as so many of you.
The printer shuts down unexpected and starts again. While initialization the platform lifts up again.
The file reports “print canceled”.

When I use “open mode” I have the same process with one exception concerning the file report:
Print failed. Print error code:41

Downgrading to Firmware rc-1.3.2-258 and PreForm 2.2.0 did’nt change anything.
It only opens a new issue, when I try to upload new files:

With PreForm 2.3.3 I see this message:

And btw: Yes, I opened a support ticket.

Thanks for opening the support ticket, Schoner. It sounds like your printer may be experiencing the brown out described above, so the team will be glad to help debug that for you. We may need to get you on a different PreForm version to be compatible with firmware 1.3.2.

Same error 41 here, just downgraded to PreForm 2.2.1 and firmware 1.3. Now I realized there is no v3 of resin available to choose on this version of software. Any ideas?

So what can you offer me, Stephen? I’m still waiting for a working solution.

Since you’re already in touch with support, they’ll continue working with you to get a resolution. Our European team in Berlin was offline yesterday for a holiday. You should have an answer about your printer and the error 41 shortly.

Thanks, Stephen. By now I have the answer: I have to send it back for replacement of the galvanometers. :frowning:

Last Friday we received our new Form2 printer and since the very beginning we are having the exact same problem. Ticket-ID: 66007

Every print stops with error code 41 and since today we also have the brownout problem which lets the machine restart in the middle of the print while canceling it.

Downgrade to PreForm 2.2.1 and firmware 1.3.2 does not work, because then our resin type “Clear FLGPCL03” is not available in the dropdown menu anymore.

Downloading the newest PreForm 2.4.0 brings us several error messages telling that some necessary files are missing to run it. And without PreForm 2.4.0 we also can’t use the newest firmware rc-1.5.7-310. The previous PreForm version 2.3.3 from last Friday morning works fine it just doesn’t work with the newest firmware and with the previous version rc-1.4.3-288 it always ends with the error code 41 or a brownout.

We would be very happy to get a solution as soon as possible. Thanks in advance!

Hi there - sorry for all the continued trouble. There was an unexpected glitch with the PreForm 2.4.0 release. It’s been corrected, so that you can now download PreForm 2.4.0 with all necessary files and upgrade your Form 2’s firmware to rc-1.5.7. Thanks for the patience. Could you confirm with your support conversation once you’ve upgraded whether this resolves the error 41 message and brownout? It’s helpful for the team to document all issues.

Thanks for your reply Stephen. Today morning we have downloaded and installed the newest version of both PreForm and the hardware firmware. At first everything was working well but after 2 hours and 10 minutes the print failed again with the exact same error code 41.

PreForm 2.4.0 together with the firmware version rc-1.5.7-310 still gives us the error code 41.

When will there be the final fix? Unfortunately we need to print new prototypes as soon as possible.

I have experienced the same problem other customers had. My first print with a custom .stl file ended abruptly after 1 layer when the printer shut off by itself and turned back on by itself. I tried the same piece a second time and the printer did the same after 5 layers. I thought that it was a problem of the .stl file so I printed a different one which failed in the same way after 15 minutes. I submitted a ticket (#66719) and tried to print the formlabs_test_pint which also failed after 10 minutes with error code: 41. I have PreForm 2.4.1 and firmware version rc-1.5.7-310. I was able to upload the diagnostic using my phone hotspot since, as others, I have IT restrictions and the printer fails to connect to my employer network both via Ethernet and WiFi. I hope these info can help others, although they seems very similar to the story of other customer in the forum.
Davide

Hi BME_Gannon

We were having that problem of the system shutting down when the WiFi was weak / bad. Turning off the Wifi fixed the issue for us. I tried printing again with the WiFi on and it shutdown again. Our issue was the Access Point for our WiFi was on the other side of the building, but I believe that any connection drops will shutdown the machine.

Also we had to roll back the firmware to rc-1.3.2-259 and use an earlier version of the PreForm (2.2.1 i think?) to fix the error code 41. I checked this form again to see if there was an update and it looks like PreForm 2.4.0 should work with rc-1.5.7 but it looks doubtful from tt_design’s post.

This may be an issue with you with newer Resin if the PreForm program doesn’t support that resin. Lucky for us, we got older resin which was supported by the older versions. (FLGPWH01 is our resin)

Has anyone else got PreForm 2.4.1 and firmware rc-1.5.7-310 to work?

Hi wfong_passy

what you are saying makes a lot of sense to me. I have read on the machine website that after uploading the model from PreForm to the printer the USB cable could be disconnected. I had assumed that when the file is loaded to the printer and the machine is printing the system is self contained and does not need to be connected to the computer. In all except 1 case when the printer shut down the USB cable was disconnected and the WiFi was on.
Yesterday night I tried to use an old desktop of the lab where I installed PreForm 2.4.1 and re-uploaded the newest firmware and shut off the wifi of the machine.
I have printed the test model maintaining the USB connected to the Computer and FormLab open and had my first successful print.

That’s great to hear you got a successful print. I still believe the USB can be disconnected though. I meant the WiFi had to be turned off while printing which was causing the issue of the printer shutting down, not the USB. Hope that helps too!