Formlabs Website Store Support

Preform 3.21.0 - Unable to send job to printer

I got the update for Preform 3.21.0 today, and for whatever reason, I cannot upload jobs to my printer now. After I’ve set up the parts, when I go to print, the “Upload Job” button is grayed out without an indication of if there’s something I can do about it, except maybe the note about remote print being disable. I’ve had remote print disabled since I got the printer, and it has never stopped me from being able to send jobs before.
Upload Job Grayed Out_2021-12-07

Has anyone else seen this? If so, how might I get around it?

I always had to enable remote printing to print remotely in all printers. I do use different vLANs so no idea if it works in the same subnet with it disabled.

I like to disable remote printing just to have that human check that all appropriate components are in place before the printer starts, but “remote print” and “upload print” are slightly different functions, where upload print should always be available.

That being said, I do have to thank @Eks for an idea. Mentioning vLANs made me remember that I’m working on a new laptop, so network communication might be a bit off even though I’m using VPN every day. I’ll try adding the specific Formlabs comm ports to the “allowed” lists and see if that helps with anything.

OKay, I tried adding ports 35 and 443 to the allowed lists on the inbound and outbound side (Firewall settings), but that didn’t work. I guess the next thing to try will be to enable the remote printing from the machine, which I’ll do the next time I’m in the office. I’ll give another update whenever that happens.

I was able to upload jobs to my Form 3L again today. It turns out that re-enabling the remote print option was all it took after all!

We’re getting the same error with the latest software update too. Maybe a bug in the software?

@TFSEngineer Possibly, but as far as I know, this one happened for me before the bad firmware updates. If not done already, I’d suggest backtracking to 1.7.6, but also checking the remote print settings on the printer. That might have been disabled at some point.

1 Like

I had a bear of a time getting 3.21.0 to accept a print job.

3.22.1 seems to have fixed the problem.

1 Like