PreForm 1.0 out in the wild

Congratulations Formlabs on hitting the 1.0 milestone with PreForm! I’m giving her a whirl as we speak. One thing I’ve already noticed: the print time estimate PreForm now provides is quite far off what the Form1 itself is estimating (17+ hrs with PreForm vs 12+ hrs on the Form1). I’m guessing PreForm is making a much rougher guess (and erring on the side of caution) given how quickly it produces the estimate, but we are looking at quite a large difference here.

Also, is a firmware update needed/available in tandem with PreForm 1.0?


Wow. Congrats on the slick new interface. However, I’m disappointed that the platform still lacks the basic labeling which will help us orientate the objects we want to print. Simple label to even indicate the peel side would be such a big win.

And it’s a pretty low lying fruit feature IMO.

I have to agree with Teck Wee Tan on this one.

However, I’m happy with the little nudges on the support platform, because I tend to have a struggle during removal of my builds from the platform. This makes it somewhat easier :slight_smile:

I checked, but the PreForm 1.0 software has the same firmware included as the previous version (1.2c I believe)

Giving the new Preform 1.0 a go. Quite a radical departure for the look and feel of the previous interface. The faster rendering is a welcome addition. The print estimate is way out and to have the estimate as grey text on grey background, I can hardly see it. Also with scaling why have 1.000 but only have 1.00 visible? The scale increase/decrease jump in uneven amounts. Also as Teck says we need basic labeling on the platform because certain orientations yield better print results. Also love the addition of the release tabs. All the best for 2014 formlabs and really looking forward to a castable resin : ) Cheers

Just completed a long-ish build, and I’m happy to say the new base ‘tabs’ for easy removal are a joy to use! The included spatula is all it takes to nudge the build off the platform, and it pops off cleanly.

Thanks for checking on the firmware version Ard.

that’s surely nice changes but when will we have manually supports ?

@Samuel, @Jesse

Thanks for the tip. We’re looking into the print time estimation and will have a fix soon.

I agree that having a positioning reference would be very helpful. I downloaded 1.0 today and tried 2 prints with the new white resin.  Both failed toward the end.  Unfortunately, I’ve had a string of print failures in the last few months, despite changing the resin tank, upgrading the software, and using fresh resin.  I’ve had my printer for over 6 months now, and I’ve noticed more failures recently with the new versions of software- particularly once the slide adjustment bars and internal support options were added.  Has anyone had similar experience?  Anyone have any prints with the white resin to share?  I’m a little frustrated because I’m unsuccessful printing now with files that worked multiple times in the past.

Just uploaded 1.0. Do I need to update the firmware as well?

I did try but there was an error.

I am trying a print now so hopefully it will be successful.

Jeannine - There could be something wrong with your unit. Make sure you shoot us a message to with photos of the failures and the files you are trying to print. We will get you back up and running!

I have to say I’m loving the little notches on the bases with 1.0. I have my cleaning station on a wobbly table and with the old bases it was a struggle to get prints to come free. It always felt like I had to us a LOT of force to wedge the spatula or razor under the bases. I was constantly causing the rinse bath to splash around and popping my prints of and they would go flying and end up on the floor. With the new notches it’s super easy to get the prints off.

Would love labels as well. How about an option to turn on a wire frame or even solid model of the form one? Then it would be really clear where the prints would be.

Also really want some kind of manual support system. Just added an idea I had to this post:

  • I agree on some orientation labeling should be included for sure, I don’t know how that simple necessity has continued to be left out.

  • But the notches are a definite big improvement although I still have a terribly hard time removing objects but mostly because of my own disability. I continue to either stab myself with a razor or fling my part across the room or both.

  • I miss the bounding box size, I found it to be extremely helpful and I don’t know why it was removed but I really want it back!

  • I am still missing controls for density and touch-point size but have submitted a ticket and Formlabs is working on that. I hope they can find a solution soon because, well because it sucks not having them.

  • My time estimates which were accurate in the previous version have gone way off as reported by others, but once a job loads to my Form 1 it displays an accurate time remaining.

  • I also find the scale amount feature to be annoyingly difficult to use and to read, its even worse now that it has a small display window that doesn’t show the entire number. And I can’t type a decimal amount in, I have to backspace into each decimal place and type a number one at a time.


Some tips you may not have noticed yet:

  • The bounding box sizes are shown when you open the ‘scale’ widget. However, if this is hard to read for you, it may not help you much.
  • Regarding the scale field: it’s a pain indeed, the way you describe it. What I tend to do myself, is select the entire field and then type in the entire number. Select the entire field with ‘Ctrl-A’ or use ‘Shift-Tab’ to select the ‘Z’ field and then use ‘Tab’ to select the Scale field again.

Hoping I’m not stating the obvious to you, only trying to help :slight_smile:

i dont know if i am the only one running the new radeon 280x cards but the preform does not show anything when loading it up. The window is blank and cant even see the build platform or the options on the side. I had moved to these cards for mining purposes and will be taking them out as soon as i build another rig and reinstalling my gtx 670

I did run the new software on my laptop with a quadro card installed and everything worked great! Still waiting for my printer to ship but i think i will be ordering some more resin cause i have so many things waiting to crank out!

For entering scale I find that if I type to slow (or my normal typing speed) that I can only enter one digit at a time. If I prepare my self before starting to enter the scale and type as fast as I can I can usually type any numbers I want in in one go. It seems to have been this way since the first preform release. Would be cool if what ever it is that thinks you have stopped typing had a longer time out or maybe didn’t boot you out of text entering until you click on something else. Or if this is meant to be a feature maybe including a preference some where where timing can be adjusted.

@Andrew Wong, I’m using a R9 280x and no issue like you described.

@Teck, what driver version are you running? These cards have been nothing but trouble for my line of work. CAD software (Solid Edge) and video editing (CS5) is just not widely supported for these cards… No big deal really as they will be running on a dedicated machine for mining as soon as my new system arrives in the mail. They were just in testing mode on my current daily machine.

@ Ard, I must admit missing the bounding box size in the scale was a total duh moment on my part, nothing new!

It would be cool if we could unlock the relation, just make the little chain link a lock/unlock button!

Perhaps formlabs might consider adding a preferences menu in preform so they could keep things like bounding box but just have a check box if you want it displayed or not instead of dropping it. Also the previous preform scale nudge was %10 +/-

PreForm 1.0 crashes on my macbook. 10.6.8.