Improvements in Printing on build platform


#1

I’m not going to clutter the board with the multiple images that led to this request. A summary; I modeled a sleeve intended to join two tube sections. Since the printing process uses much less resin when you print direct (no raft) I have used that process since it became available. The problem is that Preform then places the model directly on the platform rather than elevating it slightly and inserting supports under it.

I created a work around by inserting a small cone at the center of my circular sleeve and putting its point at Z=0, with my sleeve elevated slightly above 0 (~.375". This worked fairly well, but since my sleeve pretty much maxes out the build volume Preform places supports on the outside (where they aren’t required and then says that I can’t print, even though it gives me the green check mark, because I exceed the build volume.

Again a work around; I edited the supports, removing those whose pads crept over the lines. I then had the green check and no warnings. I sent it to the printer and it worked fine. Yes, I know how to rotate the model, but again a lot more supports to remove and more wasted resin!

There are two possible solutions to the Z=0 issue; Have preform elevate the models slightly when printing direct or allow users to manipulate the Z elevation.

With regard to Preform placing supports beyond the model that cross the deadline, simply don’t put them there.

Sidebar: Most of my prints use less than half the resin by eliminating the raft, so the workarounds are worth it and I end up with cleaner models with less cleanup. This one used ~49ml while the vertical raft version uses 197ml, quite a savings and the flat no-raft version requires much less cleanup…

It printed fine. All I did was edit out the supports whose pads were out of bounds I’ve attached some pics.

It seems to me that Preform could be modified so that it wouldn’t place supports outside the build volume. If the model fits, it should be printable, this one certainly is.

Having to add an unnecessary piece (the cone) in order to elevate the model above the platform is just wrong. Preform should never attempt to build the model directly on the build platform. If you don’t want to elevate the model automatically, at least let us do it manually. Allowing a change in the Z axis zero shouldn’t be that difficult and would allow the model to be elevated above the build platform if the user desires it.

A pic of the printed model still on the platform: .


#2

Great work around! I have started doing this as well. What a great time saver to… That big raft is such a waste of resin and time.
Agreed preform should allow you to place the model any way you want.


#3

looks great!!
But how did you eliminate the base?
is there an option to print without the raft?


#4

This is a feature of the newest version of PreForm


#5

OK, downloaded it just now.
Thank you!!


#6

When you click on the supports icon, it brings up a small window with several sliders and check boxes, the bottom check box is “On Build Platform”, if you check that box you don’t get a raft.