Form Wash Dead

My form wash seems to have no response. The LCD panel is black. Does not respond to button presses. Looking underneath the green light is on on the processor board. Plugging USB to the laptop and trying the firmware update yields no connection by USB. The same setup with my cure works fine. I’ve tried all iterations of button presses and power cycling I have found in the forum to no avail. Tried another known good power supply, no difference. And of course it died when open. Thoughts?

Sounds pretty similar to my experience.

@Mrpaul, can you describe what you did to fix your wash? IF you have more detailed photos of the the process it would be appreciated as I have zero circuitry knowledge. But I would really like to try to fix my wash.

It is relatively involved require at least some circuit board modification and the sourcing and addition of a new power supply, I would really not recommend it for the inexperienced. There is a vat of highly flammable liquid immediately above it making errors potentially very costly. It is very unfortunate that service is not available for it; I wouldn’t call the unit’s price in the ‘disposable’ range.

My Formwash dies all the time and then resuscitates.
I usually have to unplug and replug the power cord to get it running again.
Screw-up in the control design is all I can figure.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.