Form 3/3L Firmware Updates

Does anyone know what “Introduced more permissive tank reprogramming rules” and “Added automated Z-height calibration” are? I wish the release notes were more detailed :sweat_smile:

I think we need a manual which tells us what all this new stuff does or at least lets us decide whether any of it is relevant to what we are doing.

Hi @leonhart88,

Thank you for reaching out about the latest release notes! The “more permissive tank reprogramming rules” refer to easing certain restrictions on Reprogramming resin tanks. Regarding the Z-height calibrations, I believe we are working on documenting more information about the procedures. I certainly hear both of your feedback about the release notes, and I appreciate your patience with this in the meantime.

Hi @Jesse_K - thanks for the response.

What exactly does “easing restrictions” mean though? Are we able to reprogram, say, a previously used Black tank to a Tough 2000 tank knowing that the latter is more aggressive and the timelines kept by the machine and/or Dashboard will no longer be accurate?

Previously you weren’t able to reprogram tanks to any other resin that had different lifetime suggestions…meaning that sometimes if one has a tank that was barely used, they would be unable to re-use that to another resin (eg. if I am trying out a specific resin only to find out that it wasn’t useful, I may not be necessarily able to reprogram to a different resin that I often use).

Hi @leonhart88
That is a good question! I just reached out to the team for clarification. I was informed that what you are describing in your question is what would happen - you’ll get a warning giving you this as a heads-up.

The only main restriction we still have is that Biocompatible resins still cannot be reprogrammed to/from one due to complying with biocompatibility regulations.

Hope this helps!

Hi @Phil.O - amazing, thanks for clarifying that…this has been a restriction that I’ve long been hoping would be removed!


1 Like

Has anyone noticed increased print times with the firmware update? I have an almost 6 hours print that has taken almost 24 hours now. On the Z retract it is extremely slow for 20-30 seconds and then retracts at normal speed. Never had any issue until the last firmware update

1 Like

Hi @CajunCAD,

This does sound like it could be related to the updated firmware. I would recommend getting in touch with our Support Team, who will likely ask you to roll back the firmware to narrow down whether this could be causing the issue.

Good Day @Jesse_K
thanks for the reply.
I actually let the print finish. Took 24 hours to finish for a 5hr 54min print and then failed the last couple hundred layers, but only on one side.(weird). I do have 148.48 hours of print time on this machine in the past 90 days with no issues so firmware was my first thought being it’s the only variable to change.

Once the print finishing I drained the tray, cleaned everything just to check and eliminate those possibilies, rolled back firmware to 1.19.7-745 and restared the print. It hasn’t done the slow-motion retract on the Z for the 30 seconds then rapid up and back down to the resin so I’m assuming it was the firmware update, but I’ll know in the next 4hrs for sure.


Yes!!! Ours has almost tripled since the firm wear update. This crap pisses me off so bad. Every time they update the firmware is something it effects negatively

1 Like

I haven’t noticed anything strange on my end…but I have always been printing in Legacy mode on the 3L because of other issues I’ve observed with Default…but sounds like this is indeed a firmware update issue.

Does this happen on both the F3 and F3L? I usually use default settings on the F3.

@orthostar I see I’m not the only one with this issue. Hopefully they can get that fixed.

The Z retract with the new firmware is exactly 4 times slower for me for some reason. I rolled back the firmware and print times are back to being accurate and the Z retract acts as it should or same as before. 4x the actualy print time shown Preform is a pretty significant increase in time and decrease in production efficiency.

shared link with Z retract video and difference between firmwares on same print geometry. (not sure if the failure was because of the firmware or not)

You guys should create a support ticket if you haven’t already - that will expedite the issue on their side.

I’d expect to hear a lot more noise if this was wide spread…but I’ve also noticed the forums are a bit quieter these days.

I agree and I know it doesn’t take long but I’m so far down the rabbit hole on these assembliy models I’ll have to pass on tech support and creating a support ticket and just try to push through getting these clipper housings ready for production.

At least you didn’t have that problem, espicially with the 3L (i could only imagine multiply print time by 4 on a large print). I’m curious about the legacy mode, I’ve never used it. I’ve seen it but from the note on default saying it’s 20-40% faster I’ve always stuck with that. I’m using draft resin to try and speed up the iterative process time.

Congrats on the 3L btw - I want one very bad!

Yeah totally understand - make the ticket after all the work you need to get through!

I’ve spent a lot of time testing the 3L print settings…there are some issues with Default mode which is why I’m still using Legacy settings. Strangely Default settings on my Form 3 have always been fine though.

I’m actually printing something in ESD resin right now with the newest firmware…so I’ll let you know if I also observe this issue.

Thanks everyone for sharing your experience with this. As @leonhart88 mentioned, making a support ticket will be the best way for us to document and address the print time issue in addition to any print failures.

@Jesse_K As soon as I’m caught back up on the print jobs I’ll create a support ticket to make sure the issue is documents properly.

1 Like

Interestingly my ESD resin print on the Form 3 was fine…but it could be that because this resin is more niche, it has older print settings or something.

Support has told me that the team knows and is working on a solution.

1 Like

To piggyback on Jesse_K’s comment - these cases are definitely helpful for documentation, and the more eyes the support team can get on this issue, it will help with finding a solution more quickly - we appreciate everyone’s contribution and cooperation in this matter and thank you all for your patience!

I reported this to support the day after release. I’m mostly printing the same part and had been printing the day before I updated without problems.
After the update I noticed the very slow z movement, but I let it print - came back 5h later to a complete failure. Cleaned it all up and tried again, same result. That was in Durable.
I then switched to Tough 1500 - again failed, cleaned and tested a last time. Failed once more.
Contacted support, uploaded logs, pictures etc but they had no clue so I downgraded and tried one more print - success and it was back to the normal 2h print times.

This was on a brand new F3B+. Very annoying in general but also annoying to loose lots of resin and that my customers had to wait extra for parts.