Dental lt fail

I have a form2 machine, which worked fine for almost a year. Recently I switch to Dental Lt Resin and a new tank. I have printed twice, and failed twice (like picture below). Is any solutions? Many thanks in advance.

How long since your last successful print? Could be dust accumulation somewhere in the optical path. Start by inspecting and cleaning the optical window. If you open a ticket with Support, they’ll provide more personalized suggestions and (if neccessary) instruct you on inspection and cleaning of the mirror / galvos.

Could also be due to the size, geometry or orientation of your part. You could try doing an optics test and see if that prints. Before attempting a new print with that tank you’ll want to follow the steps to clean up after a failed print. Also remember to always shake the cartridge before putting it in the printer.

Thanks for your kind reply. It’s not the optical path problem. I tried a new cartridge of dental sg resin, and turned out fine. It’s the Dental Lt resin thing. Thanks again

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.