Cartridge contact problems

First cartridge through the machine, no problem. Second one, started failing, with printer reporting Unknown Consumable, and Cartridge removed. I have raised a ticket with support, but thought it might be of interest! Looked at the cartridge contacts, noticed the second one had the chip glued in at a slight angle, wondered if this could be the root of the issue?

Anyway, after cleaning the contacts, using a smear of anti corrosion contact cleaner, some drafting tape packing and the old bread knife down the left side of the cartridge trick, I still can’t get more than an hour or so of printing out of either cartridge before it stalls. There are lots of momentary Unknown Consumable and Cartridge Removed reports on screen, usually as the build platform starts to lift; vibration from the platform motor breaking a very soft contact between the cartridge and printer, freaking out the software?

To my mind, the contacts should be vertically orientated, so the weight of the cartridge keeps the contacts firmly in touch. But that’s just me…

1 Like

I think this is one of the biggest HW design issues with Form2, seen a lot of threads with this issue, and my unit had the same issue.

I have been experiencing the same issue. While using Durable V2 resin, I continuously received cartridge mismatch errors or missing cartridge errors. Just lifting up the cartridge and re-seating it would resume the print. However, this became more and more frequent, and if it paused during a long print at night there would be nothing I could do until the morning when I was expecting to come in to finished prints. My company uses our 3D printed parts primarily as jigs and fixtures on the manufacturing floor, this issue is starting to bottleneck our production process. I tried different cartridges and tanks and even purchased a brand new Durable cartridge and a new tank and the issue is still there. I’ve tried the shim down the left side and that worked for a few days. Last Friday I received a replacement for the cartridge floor assembly and swapped it out. I resumed printing today and 45 minutes in… BAM, cartridge mismatch (It says Tank is Durable but Cartridge is unknown). As @TimpErryy mentioned, the error seems to happen during or right before the peel process. I agree that something appears to be shorting out and freaks the machine out. I also have a ticket open with support. I hope they can resolve this issue soon.

I had this issue too. Everything went just like yours, and the cartridge bottom assembly did not solved the issue.
Got my printer replaced.
There might be a few cases where the issue is related with bad cartridge positioning, but in my case it was different. In order to understand that, i’ve bypassed the cartridge sensor to the outside of the machine and connected it to the cartridge with a couple alligator clips. The printer would stop detecting the cartridge anyway. I would bet on something related with the mainboard, since all my 16 cartridges were not working.
Unfortunately, there are some printers that come with this issue right away, brand new.

CPinto

1 Like

I have a cartridge of grey that neither of my machines will read. It is a pain because I am having to pour resin from that cartridge into one of the old ones.

Well… Here I am again. After having this issue, got my printer replaced in 22 November.
Replacement printer was printing well until yesterday, after 1100 hours.
-Tried a new cartridge, issue persists;
-Cleaned the contacts both of the tank and the cartridge, didn’t work;
-I tried a factory reset, didn’t work;
-Looked for EMI sources. Nothing. Also, the printer was in this exact place since it arrived, and printed 1100 hours successful;

Going to update firmware to the latest version, but the last time this happened, it did not solve the issue.
Neither the new cartridge floor…

Anyway, I am now another Formlabs very disappointed costumer. In my opinion, this is unacceptable.

CPinto

1 Like

I have been having these issues repeatedly, and find it quite exasperating.
I just bought the very expensive “Durable” cartridge, along with a brand new resin tank, and AT FIRST PRINT, it keeps giving me the “Missing cartridge” treatment.
And even after cleaning the contacts, I keep getting it again and again.
My first print with this resin is a real nightmare, and I fear that there will be marks and weaknesses on my print due to all the pauses.

I had much pain with resin sensors too, but my printer seems to be in it’s “cartridge” period at present.

Really pissed off !!!

Sorry to hear that. This is painful indeed.
Now I have to say to my costumers that my 3999€ printer is not working properly again as it should, and hope they understand.
Going to wait at least a week for the replacement printer to arrive, and pray to not have this issue right out of the box as many others…

CPinto

This level of difficulty isn’t the customer experience we strive for and hopefully this is corrected for you quickly. If you’re able to get in touch with our support team, we may have additional troubleshooting steps you can try to get the cartridge working correctly.

Hi Frew, I sent pictures of the cartridge to the support, and they said it was out of spec.
I am having a new one sent over to me.
I suppose I’m on a streak of bad luck…

I have the same issue with my Form 2 since I upgraded the Firmware in Mid December. Formlabs Support even send me a new cartridge assembly for the Form 2 that I replaced in the machine yesterday. Same problem after the exchange - I noticed that this error always shows up when the stepper motor of the wiper and the resin tank are moving. I almost think that the current consumption might be an issue. When you take the cartridge out and put it back in its recognized right away - I doubt that the contacts are the issue here. Anybody got this error solved?

OK, replacement cartridge floor fitted but I noticed while starting to reassemble the printer, there were a fair few specks of dust (dust plus, actually…) on the 45 degree mirror, and a haze of what looked like oil on the inside of the top window!! So am awaiting cleaning instructions to sort this out, before I can rebuild the machine and test it.

I am very suspicious of a current drain when the motors start working being the source of the trigger, and nothing actually to do with the contacts at all… But we will see.

I’m TimpErryy by the way, not sure how I ended up with two log-ins!!!

My printer is going back for ‘repair’ now…

Actually, I’ve decided to hang on to my printer for the moment, after a weekend of trials I don’t think there is anything wrong with it. The problem is in the software doing the cartridge checking that is at fault. I want this looked at and tested before I send my printer back, risking damage on two journeys, and the bigger risk of getting someone elses refurb back in return…

Come on Formlabs, can you step up to the mark and sort this out please?

I got the new cartridge after a long wait (snow storm in Paris).
In the mean time, I did the recent firmware update.
Bad news : the problem is still there ; it’s even getting worse and worse ; the “missing cartridge” message appears every few minutes !

Overall, there are 44 messages in this Forum related to this issue. I have read many of them, and there seems to be much speculation about the cause : out-of-spec cartridge geometry, poor design of the contacts on the printer, stray currents in the motherboard, software issues,…

Come on ! how difficult can it be to design a proper electrical contact with the current state of technology ?
I tolerate flakey contacts in cheap Chinese toys that I win in a shooting gallery at the fair, but not on a 4000$ printer !

2 Likes

What I don’t understand is why formlabs doesn’t hotfix this with a software update. There are two things that can be done :

  1. apply an hysteresis to the detection, such that momentary disconnection don’t trigger an error and stop the printer
  2. For people having this issue, allow to override this error. Or simply allow anyone to override it… I understand that some things can’t be done because they put the printer at risk (like allowing wiper in open mode), but overriding the cartridge detection issue especially once the print has started (i.e. the printer knows the right resin has been inserted) doesn’t pose any risks, at worse the cartridge is removed and there will be a resin dispense error.
4 Likes

Well, mine is going back for repair. Be interesting to see what gets done… I could not agree more with your suggestions, guys. I realise the designers are trying to protect the machine, but we are adults, we can accept or otherwise the risks of switching off certain functions, and if it prevents my business going down the tubes, which is what might happen if I have many more delays and interruptions, then I am all for it…

Of course, I’d far rather have a fully functioning machine in the first place!! Especially at £3500!!!

1 Like

Agree with JohnHue. This issue will not be fixed by sending the printer to repair or replacing the cartridge floor. I have been trying everything. So in the mean time, just keep an eye and re-insert the cartridge when needed. Hope Formlabs bring us soon a new firmware with the issue solved…

I am having this exact same issue. I thought at first it was just a defective cartridge, my very first cartridge had 0 problems. Now half way through my third cartridge (and after contacting FormLabs, they even sent a replacement cartridge) The problem is coming back. It seems to be getting worse. FormLabs please solve this!

@Frew
Anything yet? This is getting really worrying now…