Cannot update to 3.28.0

When I try to update my installation of Preform 3.27.1 nothing happens after clicking “install”. I checked the event viewer and found these entries? Any clues?

Bad service type in ._formlabs_formule._tcp.local. Application protocol name must be underscore plus 1-15 characters.

Faulting application name: PreForm_3.28.0.exe, version: 3.28.0.0, time stamp: 0x5d807032
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x6f340060
Faulting process id: 0x492c
Faulting application start time: 0x01d90f3d947028de
Faulting application path: C:\Users______\AppData\Local\Temp\Update-b6b2b611-3668-46f5-acb3-fa02785acd7f\PreForm_3.28.0.exe
Faulting module path: unknown
Report Id: 9dea6ab1-0e11-49e1-a7f4-5af488083e7f
*Faulting package full name: *
*Faulting package-relative application ID: *

Fault bucket 2091141574997035908, type 5
Event Name: BEX
Response: Not available
Cab Id: 0

Problem signature:
P1: PreForm_3.28.0.exe
P2: 3.28.0.0
P3: 5d807032
P4: StackHash_b355
P5: 0.0.0.0
P6: 00000000
P7: PCH_8E_FROM_unknown+0x00000000
P8: c0000005
P9: 00000008
P10:

Thanks.

Hi Andrew_W,

Sorry to hear you are experiencing issues updating to 3.28.0. Upon looking over Event Viewer - I would try running the installer as Administrator. I see that the installer might be a temporary file, I would try the installer from our PreForm downloads and release notes (formlabs.com) page.

Sometimes the issue can be related to a multiple monitor setup - I would try making sure to see if this issue persists with a single screen.

If you are still having issues, I suggest that you create a support case with our support team and provide the PreForm logs so they will be able to investigate the issue further. Hope this helps!

I tried with single monitor and Administrator rights using a downloaded file, still no-go.

I’ll open a support case.

2 Likes

Hi Andrew_W,

Sounds good. I am curious on what the issue ended up being myself. Thanks for giving those steps a try!