Cannot unlink Size dimension in PreForm 1.7

I used to be able to change the X, Y or Z dimensions independently in PreForm. Somewhere in one of the updates, clicking on the linked chain does not unlink the dimensions. Any idea how I do that now? I’m using PreForm 1.7 on Windows and have had a friend confirm that he can also not do this on his Mac.


I don’t have this issue. I’m running Preform 1.7.1 on windows 8.1.

I didn’t have this problem in 1.7, and neither do I have this problem in 1.7.1. Have you upgraded it yet?


I was using 1.7, but the problem persists after just upgrading just now to 1.7.1.

I’m on Windows 8.1 x64 Enterprise.

I opened up one of my recent .form files, saved it with 1.7.1 and it was still a problem.

I also tried creating a new file adding in the .stl and it still doesn’t let me unlink the scaling. The STL opens cleanly and does not report needing to be repaired. Let me know if you want to try with this particular STL in case there is something in the file, but my friend tried with a completely different file that he had.


@Jonathan_Hunt, scaling dimensions independently of each other has never been a feature in PreForm. If the dimension boxes are greyed out, you can enable them by clicking on the model in your file.

Ahh… sorry, I was under the impression you were talking about changing the dimensions… not scaling! Indeed. Scaling has always been coherent on XYZ.

I think what you are looking for is Help>>Fine Tuning>>X/Y Scale. If really desired, you can play with Z scale by making that adjustment on the master scale control, then using the Fine Tuning settings I mentioned to reverse the effect in the X and Y direction.