Unsupported minima - in the supports


#1

Hey All - I have modeled this three times. Blender, then blender and Zbrush, then just Zbrush. Every version has had unsupported minima, but in the supports themselves.

The red minima can be seen through the models in the screenshot.

Additionally, all versions of thie model (from the various modeling packages) have occasionally caused Preform to crash. I have no idea what the reason. All drivers and software are up to date, and the triangle count on the models is very low.

Any thoughts? Thanks.


#2

Hi,
I already got the same problem with the latest PreForm software and filed a bug ticket. From FormLabs they explained that the bug is known, they work on it and they will fix it in the next version of the software.

Actually there are two problems with PreForm - minima inside supports area and second - supports on very shallow angle (close to horizontal).


#3

Thank you for letting me know. I will file a bug ticket as well perhaps. Squeaky wheels…


#4

Is this particular to 3.4.1? I reverted back to 3.4.0 recently and curious if this bug still exists in that version.


#5

I am using 3.4.1. I will revert to 3.4.0 and see if it still happens.

@leonhart88 - Where did you get 3.4.0? I can’t find a download page for it.


#6

It’s on the same page as 3.4.1. Just Google Preform releases and scroll down to the old version release notes. There will be a download link.

Also, they released 3.4.2 today which might fix it.


#7

I can confirm that in PreForm 3.4.2 the problems with minima in supports and shallow angle supports were fixed. And you can see how supports look different - they added smooth transition between supports, really a good fixture of the problem.


#8

Strange, as I continue to have the issue. I think my studio has gremlins!


#9

Hi,
You need to clear the supports and generate again but without moving/rotating the objects.
If you just load the FORM file - nothing changes


#10

I thought I had done that but will try again. I have been juggling multiple projects so I very likely spaced. Thank you for the reminder.


#11

Turns out I needed to uninstall/reinstall 3.4.2. Works like a charm now.


#12

Looks like I spoke too soon. It’s back.


#13

Oddly, if I load up a previous .form file that “passed”, deleted the model, imported my new model and built supports, it comes out fine and passes for print.

I’ve also been experiencing issues where the scale was way off. It looked right in the viewport, but in looking in the scale module, it was reported as being much smaller.

What is up?


#14

Any change in position/rotation of the detail will generate completely new supports and this problem occurs ONLY in some specific circumstances, So probably the new position is free from this minima in supports and this is actually the patch they proposed from FormLabs - change/rotate the detail until minima is gone and wait for the new release of the software.


#15

Ok thanks. I have tried multiple position/rotations but will continue to try the technique with the next job.

Fortunately, opening a previous file and swapping models worked and I had a successful print last night.


#16

You’re not crazy! We’ve been able to reproduce this bug and are working on the fix. It was introduced just for White resin in PreForm 3.4.0, so if you go back to PreForm 3.3.3 for the time being it should go away (you can get old PreForm versions here, just scroll down: https://support.formlabs.com/s/article/PreForm-Release-Notes).

We get the fix out as soon as we can!


#17

That’s up for debate. :smile:

Thanks for the update, and link to 3.3.3.


#18

I definitely see this in 3.4.2 - especially with the introduction of the fillets in the supports. Some filleted areas will hang as unsupported minima.

I also notice that 3.4.2 seems more buggy, laggy, and is prone to crashing more (just crashed on me now).

3.4.0 seems to be fairly stable, although I do notice that sometimes the minima check is dodgy (sometimes it switches from pass to fail if I manually edit supports, even if all I do is add a couple of extra supports here and there, or simply remove an existing auto generated support and add it back manually). Regardless, I’m using that right now with good results although I feel like I’m missing some of the speed benefits that the newer version may bring.

I’m actually pretty disappointed in the firmware updates so far (3.4.0 and up). They seem rushed & buggy, and I’m still waiting for the speed improvements that have been promised for >4 months now.