Resin Tank "None" but it's actually not


#1

The resin tank of my formlab 2 is properly installed to the printer, but in the settings, it says “Resin Tank None” and in PreForm it shows that the resin tank is missing. However, in the dashboard, the status is “unknown”.
So I suppose this might be some software error?
I have successfully printed many times but it suddenly cannot recognize the tank.
Appreciate if anyone can help, thanks~


#2

It’s probably just dirty contacts. Remove the tank and clean the spring-contacts on the printer with a cotton bud or piece of tissue and some IPA. Also clean the contacts on the bottom of the tank with a cotton bud. It’s not recommended to use IPA on the tank though. Hopefully that will sort it for you.


#3

but be careful- those spring contacts are the most delicate thing in the whole machine.
Very easily bent.
they are not spring steel, for some unknown reason, and suffer plastic deformation even with careful ordinary use- not springing back as high as they once did- you can expect the problem of undetected tanks and cartridges to get worse over time.

Probably the worst piece of design by formlabs was to rely on such fragile contacts for both tank and cartridge registration.
I wish to god they had gone with near field RFID- or even a simple optical readout of a serial pattern printed on each unit.


#4

Thanks for your reply! I tried another resin tank and I found the printer could detect it. So I guess there may be some problem with the resin tank but I cleaned everything I could and the issue remains. I gave up and used open mode to print. Thanks anyway~


#5

What he said.


#6

Try the masking tape or duct tape method. About 8 to 10 layers on the bottom of the cartridge’s front and back edges to raise the cartridge enough to make contact with springs. I had to get with Formlabs support to learn this trick.


#7

I had the same issue with my LT tank and contacted customer support and the gave me the following tips. In my case Tip 2 worked when I twisted the tank counterclockwise a little after the tank is mounted. I guess there was a slight misalignment of the contact on my tank.

Blockquote

First, I’d like you to try reseating the tank:

  1. Reinsert the tank using the appropriate technique and push the tank all the way in. Press firmly to ensure the tank is fully seated.

  2. If the tank remains undetected, “twist” the tank by applying a slight counter-clockwise force. The tank may not perceptibly move.

Next, try using a q-tip and a little IPA to clean off any contamination that may be covering the ID chip on the bottom of the tank.

Blockquote