Print super slow. "Sensing Resin" between every layer

Dear formlabs,

It appears that due to the newest resin counting issue and resulting spurious “cartridge empty” warning, the printer will now do “Sensing Resin” after EVERY LAYER !!!

Obviously, that more than halves the printing speed. The resin cartridge in question is still roughly 30% full, so I feel like I shouldn’t throw away 50€ of resin and buy a new one. But the printer thinks it’s empty and that has triggered some sort of bug.

  • How do I work around these issues?
  • I have the most recent stable firmware. Are there any beta updates to try?
  • Can I re-calibrate the “resin used” sensor somehow?
  • Should I send the printer in for repairs?
  • If the hardware/software bugs cannot be fixed, is there some sort of rebate that’ll give me 50% off on all resin purchases? 50% because the printer decides it to be empty after roughly 500mL are used.
  • What are my options?
1 Like

This is normal behaviour.

The printer checks every layer to be sure there is resin in the tank.

Yeah. But his point is that the printer doesn’t do a good job of estimating how much resin is left in the tank. Both the Form2 and Form3 appear to suffer from the same problem. The printer will say the cartridge is out of resin when there is (at least as far as my experience goes) almost half a cartridge full left in the cartridge. When the printer thinks the cartridge is dry, whether or not it is dry, it goes in to this “limp along” mode that slows down print speed by an order of magnitude (maybe a slight exaggeration)…

I’m pretty sure it’s not. I printed the same file twice and one time it took 3 hours, the other time it took 8 hours. So when the printer enters it’s “cartridge empty” mode- no matter if justified or not - it’ll make printing a lot slower.

Plus there isn’t really any good reason to check every layer. The tank contains 200+ mL, so printing 10 layers in-between checks should be fine, too.

To me, this looks more like deliberate harassment that Formlabs added to prevent people from re-filling an empty cartridge with 3rd party resin. That’s why I feel extra offended that I have to deal with this shit despite paying the premium to buy the official resin.

I wanted a printer that “just works” and bought what I thought is a premium model. Yet here I am, doing their QA by diagnosing buggy firmware and software while paying for the wasted resin myself :sweat_smile:

BTW I installed a new resin cartridge and now it’s not doing the “Sensing Resin” anymore. That confirms my suspicion that this behavior is triggered only if the printer shows the “cartridge empty” warning.

Now the question is: What do I do with the “old” cartridge? It’s roughly half full, but the printer thinks it’s empty. So when I try to use it, it’ll trigger the bug described here. But I wouldn’t want to throw away €50-€100 in perfectly good resin just because of a software error.

Anybody figured out a workaround to this yet?

I’ve discovered that this also happens if you marry resin cartridges. Which is extremely frustrating, because this issue makes it so you tend to replace your cartridges before they’re empty, meaning you have a bunch of almost-but-not-fully-empty bottles piling up. It would be really nice it if it wasn’t such a hassle to use up all that perfectly good resin.

Can’t you pure some of the resin directly to the tank before start printing? (from your almost-empty bottles)

I sure hope so because that’s what I’ve been doing when I clean the tank I fill it out of the bottles that have just a bit left , so far not a problem , way to expensive to throw away

1 Like

That doesn’t work if you’re waiting for a shipment of new resin and all you have is nearly-empty bottles and you need a print done today. The problem is the printer being snippy because the bottle is nearly empty, it doesn’t matter how full the tank is.

However, in the future this is probably what I’ll do before throwing out old bottles. No more marrying anymore.

1 Like

Sadly I have the same issue and the Formlabs printer feels like a 200$ product. Efficiency = 0.

P.S.: My private Anycubic Photon Mono is quicker and cheaper than Formlabs machines. Pretty embaressing in my opinion.

Me, too. The “resin used” counter of the cartridges is still living in an alternate reality.

For example, I have one Tank for Clear resin that says I used 1.4 L with that tank, but when I look at the 2 cartridges it says 1.3 L and 2.3 L used. So according to the dashboard, out of the 3.6 L drained out of the 2 cartridges, only 1.4 L ever made it into the tank :sweat_smile: And due to quantum tunneling, I guess, the magical machine found 2.3 L inside a 1 L container :rofl:

My current estimate is that “resin used” is roughly 4x of the actual resin use. That cartridge saying 2.3 L used is still about half full (when compared to the weights of an empty and a new cartridge).

Hi @fxtentacle,

Thank you for getting in touch. The cartridge with 2.3 L used is certainly unusual, especially if the tank or cartridge were not manually refilled outside of printing. The resin usage tracked for each cartridge should correspond to the model volume estimates in PreForm. With that said, I appreciate you working around the issue by weighing the cartridges as you mentioned.

Well, I don’t have much choice other than working around the issue, right? Or did you expect me to throw away a $3000 machine because of a bad firmware update? If there is any kind of calibration that your support team could do to fix the issue, I would very much like to try that. But in the past, I have been told that the issue was un-fixable so my only option would be to buy another 3D printer. :frowning_face:

BTW, here’s a picture of the next Clear resin cartridge, which is off by about factor 5x. I used it with a full tank, so no resin was used for initialization. And I had one 123 mL print fail after about 200 out of 1400 layers (i.e. 14% == 17 mL) and then I did one successful 83 mL print. So I would estimate that about 100 mL were used in total. Maybe let’s be generous and assume 20 mL wasted from cleaning the print bed. Then the real usage would be 120 mL while the dashboard wrongly proclaims 580 mL. So for this cartridge, I expect that I can run it until “Resin Used” shows about 5000 mL because that’ll correspond to 1000 mL in reality.

But that means I will see that annoying “Sensing Resin” and those annoying “Cartridge Low” warnings for about 80% of the usable life of this cartridge. :roll_eyes:

And I chose this as an example because there’s no way I could have caused this problem. Even if I would refill the cartridge (which I never did and do not plan to ever do) there is no excuse for why the printer would assume 580 mL of resin use for a 83 mL print with a full tank. The only way how this could be an user error is if the resin tank was leaking … but that is very easy to check and no it isn’t. So this example shows that it is 100% sure a firmware bug.

So in the end, maybe I should buy one of those auto-reset cartridges. Not because I plan to use 3rd party resin, but because it apparently is needed to make this printer work well with the official resin :sweat_smile: And in case your product department ever asks why so many people buy 3rd party resin: it might just be that it provides a superior user experience :face_with_raised_eyebrow:

WTF? That cartridge dropped over night from 420 mL left to 40 mL left. Within 12 hours. I’m pretty sure it is not even possible to print 380 mL of resin on a single machine in only 12h. That print should take about 124 mL when it’s finished (which it isn’t yet) so again the machine has overestimated resin use by about 4x.

Here’s the ongoing print that I started yesterday:

Hi @fxtentacle,

Thank you for the added detail here. I understand the inconvenience with this, and it certainly seems that the Dashboard resin level estimates are quite off. It is true that we do not have a calibration specifically for this. One thing you could try, at least to potentially avoid delays during the print itself, would be Open Mode. This disables certain features during printing including resin level sensing.

I’m aware of Open Mode, but sadly that won’t work well for me because I typically run 120 mL prints over night. Accordingly, Open Mode would pause printing sometime in the middle of the night and wait for me to refill resin, which means the part wouldn’t be finished when I come back the next morning.

Thanks to the printer now locking me out of using the half-full cartridge with a “This cartridge has exceeded its lifespan and must be replaced” warning that only allows “Abort Print” or “Try Again”, I was now forced to try out Open Mode.

Sadly, it appears that authentic Formlabs Clear Resin V4 is effectively unusable in Open Mode :disappointed: :sob:

Open Mode disables the heating and at only 18 degrees, the resin seems to not activate well when the laser hits it. The printing properties between “Formlabs Clear Resin V4 - Closed Mode” and “Formlabs Clear Resin V4 - Open Mode” changed so drastically that a print job which had previously worked just fine now fell off the supports. Plus the part that did print has serious distortions along the Z axis.

So I guess “Open Mode” really only works with 3rd party resins, but not with the resin left in my Formlabs cartridges.

It appears that this is a === :fire: heating issue :fire: ===

When I start a print, the printer will usually try to dispense resin before it started heating, at which point it only slowly drips out. Sometimes it will even complain that the cartridge is clogged. But later during the actual print, it almost dispenses a bit too much resin because sometimes the tank will be more full than the top line at the end of a print.

So I ran a little experiment: I started the print, but pulled out the cartridge just a little bit. Apparently, heating will still continue in the background. Then when the printer was warm, I pushed the cartridge back fully in. This time, A LOT of resin came out already on the first time I could hear the motor activate. With that, filling the tank finished A LOT quicker than usual. And the online resin counter only increased by 0.1 L for a 50 mL print which seems a lot more reasonable than the usual 4x overcounting.

The printer just locked me out of Cartridge ID 4c-00000068a414 and the dashboard claims Resin Used 2.1 L while actually there still was a bit more than 60 mL of resin left in the cartridge, meaning about 9,60€ lost :sob:. But in comparison to the last 2 cartridges, that’s actually much better already. Previously, it overestimated by about 4x, now it’s down to 2.23x so my impression so far is that the heating trick very much improved the situation :grinning:

… and mere minutes later, the next Formlabs Clear V4 cartridge is failing me :roll_eyes: Maybe, in the end, this entire issue is just down to extremely bad QA?

Say hello to Cartridge ID 4c-0000006bf649 which was completely new and unused when I put it into the printer:

And it refuses to be used:

Because no matter how hard I squeeze that valve, it just won’t open more than a tiny little dot:

and needless to say, no resin is coming through.

In this case, the cut is completely missing from the cartridge. That’s an obvious production fault. But apparently it still made it through QA :thinking:. I could imagine that for other cartridges, this cut might have been there in general, but just a bit too short, which would then cause the resin to flow slower than it should, thereby leading to the printer overestimating the resin used up with each squeeze of the valve.