Preform calculation speed - is this the slowest?


My PC has been chugging away for almost 8 hours and the calculation process is not even 75% complete yet (granted the model is complex and takes up the maximum build volume, and is set to 0.025). Anybody else experienced similar times?


Total print time estimated at 64 hours - would that include the pc calculation time?

Ta :slight_smile:

I noticed the latest version of the software 0.9.1  is super slow and inaccurate when it comes to the calculation and the upload of the model. It told me the print would take 4.5 hours to print, but once on the printer the time was 3 hours and 20 minutes.

@Jason 8 hours is far outside the typical calculation time for a model, though it is not out of the realm of possibility depending on how complex a model is. If you would be willing to share your model with customer support we would be happy to take a look at it to see what is causing the slow down.

@Monger Designs Because of the approximate nature of the print time estimator it can under/over estimate the print time for certain geometries. We are always working on improving the estimates. If you could share your model with customer support it would be a big help for us to trace the inaccuracy.

Im having the same trouble Jason…@Shane W was this ever solved. I have had a character, nearly full build volume that took 3 hours to to upload to the printer. Support generation is slow as well…I had a very simple umbrella I made for my daughter that took nearly 20 mins to upload. So my main trouble is PC to printer upload times…Im using Preform 0.9.2

Simple specs : Win7 SP1, 4G RAM, Nvidia 9600M GT 512MB

sorry Jason wasnt trying to over take…

Cheers Ant


Hi Anthony

It was never solved, however I think the model may have been responsible for the excessive time to load the file - it eventually took 22 hours! On further analysis the stl file had some serious errors in it and it was large - 48 mb. All my subsequent files have printed in a much more respectable time.


thanks for the reply mate. No my models have been through netfabb and even Magics so geo issue I dont think it is. I have just tried to upload the umbrella again and it was a 10 minute wait! just for an upload! My character was only 10m file, that took between 3-4 hours just to upload to the printer!!! I have learnt NOT to start a print now before its uploaded. Also trying to restart a print/upload is bollocks as my printer is not detected, the Form tab is greyed out and I have tried all sorts of crap to get it to reupload. I might retro the preform back a notch and see if that makes a difference.

Cheers Ant

Hm, I’m sorry to hear that, Anthony. Is your Form 1 still not being recognized? You should definitely get in touch with our support team at, who can take a look at the details of your configuration and see what can be done. While streaming a model to the Form 1 can take some time, it sounds like something is amiss with the USB connection.

As for the time it’s taking for supports to generate and stream the model to the printer – I took at a look at your umbrella file, and uploaded it to the printer in about a minute and a half. The problems you’re seeing may be related to the recognition issues you’re describing.

Hi @Sam

The printer is recognised** BUT if the upload is interrupted then it wont let me re upload, doesnt see the printer…I will scour the FAQ again. The support generation takes a fair while but his I can live with. Its as you say maybe a USB thing, It took 15-20 mins for a dinosaur to upload last night, not a complex model at all.

Cheers Ant**