Formlabs Website Store Support

PreForm 3.18.0 bug disables "Upload Job" for unknown reason - re-installing 3.17.0 fixes it

Hi there,

I’m having a rather annoying problem. PreForm doesn’t allow me to click the “Upload Job” button because there’s a warning message that it thinks the resin is low. But that’s entirely due to the horribly broken resin counting. (See my other thread)

In reality, the cartridge is half full :sweat_smile: According to the dashboard in the tank (not the cartridge), I’ve used 270 mL so far.

So how do I work around this error?

Capture

Did you actually click the Upload button and get no response? I’ve run in to this issue myself and it uploaded the print no problem. Took the printer forever to start the job, and then it slows down between layers on the assumption the low resin level means more time required for resin to flow back before the next layer can be printed, so the print took a long time. But it did run in spite of the warning…

Yes, I clicked the “Upload Job” button many times, but it didn’t do a thing. Also, I tried opening and closing the Print dialog. I also saved the project, restarted PreForm and reloaded it and still couldn’t print.

If I remember correctly, it was a slightly more yellow-ish color before and the text was bright white. So in comparison with that, the Upload Job button in my screenshot looks “deactivated” to me.

It appears this is a bug in PreForm 3.18.0. Uninstalling it, then re-installing 3.17.0, then declining the update appears to have fixed the issue in the sense that it let me upload the job into the printer. And - surprise! - resin came out of the cartridge just fine. :grinning: :roll_eyes:

Probably unrelated but, whenever I try to print a job to a disconnected printer (either powered off or out of the network) I get disabled button BUT I have to restart Preform after making the printer available (even after reopening the print dialog, selecting another printer and then the one that wasn’t there). Kind of annoying.

Yes, I encountered that, too. But in this case, I did restart PreForm just in case, but that didn’t help.

Actually, Preform thinks the cartridge is missing, once the red colour.

@billb I don’t think so because PreForm 3.17.0 shows it in red just the same and that one will let me upload the print job anyway:

Capture2

I believe it’s red because the printer thinks it’s empty. But it’s not.

Have you tried lifting the cartridge out and replacing it? Just the ‘feel’ of the weight will tell you if it is empty or not. If the chip on the cartridge is not making a good contact then you will get spurious level readings.

This and other similar threads remind me of something Scottie (USS Enterprise Chief Engineer Montgomery Scott for those that forgot) once said about the new-fangled USS Excelsior:

@billb when I managed to start the print with PreForm 3.17.0 then resin came out of the cartridge just fine, so it certainly wasn’t fully empty. And when I took it out just now, it feels like it’s still pretty full. I can also hear the resin inside make splashing sounds when I rotate it.

@Dudemeister yeah I wish the dashboard would just display me a list that sums up the “Resin Used” of everything that I printed with that cartridge. And maybe it’ll add a fixed 260mL for filling up a new tank with it. That would allow me to make an informed decision. But instead I now have to click away the “your cartridge is empty” warning for every print, and since I mostly print small stuff, I can look forward to doing that 10x to 20x times more before the cartridge is actually empty.

You could try cleaning the chips on the cartridge with some IPA. Cartridges vary some the next one may work as expected.

I encountered this the other day. Not really sure it’s related to resin levels but a restart of perform fixed this for me. Looks like it’s just a bug.

Hi everyone,

Resin tracking should never stop a print from uploading. If you are encountering this issue, try restarting your installation of PreForm. Alternatively, the issue may be that the printer is not detecting your resin cartridge. This can occur when there is little-to-no resin left in the cartridge, in which case it should be replaced. If the cartridge is still somewhat full, you can try cleaning the ID chip with some isopropyl alcohol.

If you’re still encountering difficulties, please reach out to our support team. They’ll be happy to get you back to printing as quickly as possible!

Thanks @Jackson for clarifying that the resin tracking will not block the “Upload Job” button. Since switching to PreForm 3.17.0 fixed the issue for me without even touching the printer, I’m going to assume that I hit an unknown bug in 3.18.0. I have also changed the thread title accordingly.

As for the missing cartridge, can that prevent the “Upload Job” button from working? For example, I can upload jobs for Color resin just fine while the printer still has Clear resin inside. PreForm will warn me about the material mismatch, but I can still upload the job into the printer’s queue. Since PreForm does not block the upload when the wrong cartridge is inside, I would assume that it’ll also allow an upload without cartridge in the printer.

Hi @fxtentacle,

Thanks for the update! I’ve submitted this bug to our team, and I’ll be sure to let you know when it is resolved.

With regards to the missing cartridge, it will not prevent the “Upload Job” button from working. However, you will need to insert the cartridge before starting the print on your machine. If the “Upload Job” button is not working, the issue is likely the PreForm bug mentioned above. Sorry if that wasn’t clear!

Editing the Job Name, works for me