NO I don't want to Improve/Send any FORM files to Formlabs!

Why after a year or more am I still asked if I want to endorse 2 checkboxes each time I open Preform?!?


Just for further clarification, it “remembers” the checkbox to remain unchecked but what I want is NO POPUP AT ALL!!


Hi @bolsoncerrado,

My apologies for the hassle with this. I believe the pop-up box that appears when PreForm opens should remember your selection on subsequent launches. Since that does not seem to be the case, you can submit feedback regarding this under “Help → Give Feedback” in PreForm.

This is happening since at least a year, pretty anoying. At least it remembers your selection, it is not fix by runing in admin mode (just in case was the reason it could no store the selection made)
And is even more annoying as, i imagine for many of us, the question os sending form files automatically is an absolute NO. This are in many cases prototype machines, client parts, etc. No, we do not have de right to sen 3D design without consent, because they are private R&D models, copyright and data protection, etc.
Even if the option is not marked by default, I would be not sure if it is a pass, at least for european private data protection (there is no info for example in which country the data will be stored.
i suggest the option is directly removed, anybody with issues will open a ticket manually.

1 Like

As Jorge said, this is a LONG DUE issue with MANY preform versions prior this, nothing “local” on my side… :confused:

Just for further clarification, it “remembers” the checkbox to remain unchecked but what I want is NO POPUP AT ALL!!

Hi @bolsoncerrado,

Understood - after running this by a few of my colleagues, this behavior in PreForm does not seem to be working as intended. The pop-up should only appear once, after which PreForm should no longer display the pop-up. In order for us to document this issue and determine why this might be happening, please get in touch with our Support Team. They will be able to collect diagnostic logs for PreForm which would help track down this issue.

Hi all,

I wanted to provide an update on this issue. It’s possible that this behavior is due to a local registry issue. In order to address this, please try cleaning the registry following these steps:

  1. Close PreForm.
  2. Delete settings (see below):


  • Open the registry editor regedit.exe (admin rights are needed).
  • Locate the following key: Computer\HKEY_CURRENT_USER\SOFTWARE\Formlabs\PreForm and delete it.


  • Locate the application settings plist file /Users//Library/Preferences/com.formlabs.PreForm.plist and delete it.

After this, when relaunching PreForm, the pop-up should only display the first time PreForm is opened.


I’m sorry to report the trick didnt work for me on MacM1 running Ventura OS.

Now I’m worse than before as I must untick in addition to close the popup.


Hi @bolsoncerrado,

My apologies - I had not intended for this to make the menu more inconvenient. Sharing your PreForm diagnostic logs with our Support team will be the best way for us to determine why this behavior is still persisting. They will be able to share instructions for getting the logs to them.

It worked for me in Windows 10. Thanks

1 Like

@bolsoncerrado thank you for posting this, it was frustrating me as well. Jesse, thank you for posting the fix. I didn’t feel comfortable deleting the entire Preform registry setting so I poked around and deleting HKEY_CURRENT_USER\SOFTWARE\Formlabs\PreForm\DataCollectionConsent and re-launching Preform worked for me.

1 Like

I’m puzzled as to following the same logic on Macs won’t work, but oh well, glad it did for you Windows users :slight_smile:

I just upgraded to the latest 3.28.1 of Preform and the two checkbox bug returned. The registry fix above still works.

Hi @poday,

I appreciate the update. Our team is actively looking into this, keeping in mind that the fix I suggested has seemed to work for Windows users but not for Mac users. It’s also helpful for us to know that the issue came back on 3.28.1 with the same fix still being effective.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.