New support generation system in version 0.9

While the new support system seem very innovative, I’m getting lots of problems trying to print my models with it.

Models that used to print just fine with the old system, show up lots of red shaded areas, no matter how I orient the model, or use the auto orient button.

The internal supports seem to only work on certain large areas. I have lots of internal space on this model, yet no internal supports, therefore lots of red shaded areas. With the old software, the supports were smart enough to go through an opening and to support the internal structure.

Not sure what to do. Should I uninstall and use the old version?

Here is a screenshot. I used Auto Orient and the default settings. And there is also a version of me rotating the model more for better support. Still no go.

I’ve also been having a lot of problems with the new supports. A lot of points won’t even reach some of the really simple overhangs that the old supports used to catch. I’m going to roll back to the previous version since the new version ignores the old supports.

I’m hoping the version following will have an improved version of the new supports, but if not, I’ll have to stick with the old version, or build my own supports.

Monger, have you tried to increasing the support density and lowering the touch point size?  When I do so, I end up with a much more supported model (see screenshot).  There’s still some red shading, but I suspect it would print just fine.

-Tj-,  if you open a ticket with an example file, I’ll check it out.


I’m not getting the results you are getting. No matter how I orient the model, or use Auto Orient, I still get the same results. Even with the density all the way up and the touch-point size all the way down. There are large red shaded areas.

I noticed that you use the mac version. Maybe the mac version and the pc versions are different? Perhaps there is a bug in the pc version.

Oh, that’s because I had loaded and saved the .form file (which clears the red shading).

Right after generating supports, I still see red shading (more or less depending on orientation), but I’m using my own judgment / experience when I say it looks like it will come out fine.

I can try it out on one of our in-house printers early next week (once Makerfaire wraps up) if you don’t want to try it yourself.

I am trying a print, but I notice that the grey resin left in the tank for about 6 days, has separated from the pigment, and is leaving a residue on the bottom of the tank. I made a separate post about it.

I gave some of the suggestions above a try and with different angles, but I couldn’t quite get it to cover everything. The part is small with a lot of overhangs and hanging parts, and it has some small holes here and there that the older supports could fit through but the newer ones apparently can’t. Unfortunately I can’t share the part since I’m printing the file for someone else, and ended up using the older version to print. I’ll give the newer version a try with some of my own prints afterward.

Good news. The red shading did not seem to affect the final print. It came out just fine. Still not knowing if the red shading is an accurate guide or not, kinda defeats the purpose of it. The model is still in the ipa bath. Will see how easy it peels off the new supports.

This new version doesn’t seem right… I dont have any sliders for support density of the touch-point sizes, nor can i click the internal supports option. Like the options in the supports generator are there, but no slides and the check box is greyed out. I hope they fix these issues before my printer comes!

I am running windows 7 64 bit, 2500k OC to 4.8ghz + gtz 670 4gb…


I would suggest re-installing PreForm to see if that fixes your issue. If the problem persists, could you take a screen cast and submit the video to us for evaluation? You can submit a screen cast through our ticketing system here:

Hey guys,

Im conducting a little bit of a survey. After going trough plenty of posts im noticing a pattern here… it seems like the form1 is simply unable to print large models with any amount of consistency…

If you have been able to print large models consistently, say more than 5 without a fail, please let me know here:

For the purposes of this discussion, lets define large as a larger than 10cm sans supports on the longest axis… c’mon large, you know what I mean…