New Preform version question

I just installed the latest version of Preform and upgraded my printer firmware.
One thing that I’m finding an issue is Preform seems to insist I have a resin cartridge. it shows Open mode but won’t let me select that.
How does one turn on Open Mode in Preform Ver. 3.12.2

What does preform say?

I installed 3.12.2 om my macbook and it doesn’t complain if I don’t have a cartridge installed or if I am in open mode? I can still upload my prints to the printer in any of these cases.

Preform appears to be running OK on Windows 10. There is no cartridge in the machine but it shows that there is. Won’t let me select Open Mode. I then went to the printer and set Open Mode int he settings but nothing changed in Preform. It sees it as a Form 2 so it should allow Open Mode?

That’s odd! Can’t replicate it in any way here.

Well I worked around it. Now filling the resin tray and the heat is up to temp. We;ll see how it goes from here.
Looks lit the resin tray is filled at the from because it’s up to the top line but not so at the back of the tray. Machine is level so not sure why. Hopefully it gets printing in a bit.

Here’s the MESS I got on the first print using the latest Preform and Firmware.
There’s a new tray and the Galvo, Mirror and Glass have been cleaned 3 times in 3 days.
Someone mentioned the touch point sizes. It’s .35mm and I’ve used that for YEARS with the OLD preform and firmware. I’m going to do a test of two setting using first .40mm and the other using .45mm much larger and my parts would be useless as too much cleaning. I print anywhere from 50 to 150+ parts on a build plate.

This same part ran with same touch points a few days ago on the old preform and firmware. Only issue was the scumming which got all over the parts and couldn’t clean.


You can still go back to the old firmware. I would do that to see if this does solve your issue.

Yes, I saved the install file for that. Formlabs Tech is INSISTING I stay with the new Preform.

I’m reaching the point of replacing the Form 2 printers with either the MONO-X or the S-BOX printers. Far less cost a large build plate and seem to run well. I like the fact you can replace the the FPE film on the tray real easy so your not paying $100 a wack plus shipping for a new tray. I’ve reached my breaking point on this after over a month of issues.

Had problems with the new PreForm 3.12 also. Print quality for all of my printers, one Form 3 and two Form 2s, was affected. The problems I experienced were a bit different, but perhaps your issues and mine are related.

After updating PreForm from 3.11.1 to 3.12 and firmware for all of my printers, models of a ship’s smokestack printed but none of the surface rivet detail was there (see comparison photos below). The basic smokestack structure itself prints fine but the surface rivet detail was gone and the models looked kind of mushy, with edges not as crisp and sharp as before.

After corresponding with with FL support, I rolled back PreForm to 3.11.1 and ran the prints again. The surface detail reappeared and the model printed normally. I did not roll back the firmware, just PreForm.

My models are printed with standard gray V4 resin. The loss of surface detail was observed in prints at 50 microns and 25 microns.

FL reports that they are investigating. Among several possible causes being looked into, their rep stated, “Some iterations of PreForm make tiny adjustments to the way the printer “treats” the resin (how strong/fast to fire the laser, how hot to preheat the resin, how fast to move any particular motor, etc etc)—this can mean that older iterations of the .form file will perform poorly, especially with certain factors like extra-small touchpoints brought into the mix.”

This means that support generation for older versions of PreForm may need to be regenerated in the most recent PreForm version before printing. Depending on how many models you have, that could be a daunting task.

In the following message, FL support wrote, "To get into the updates I mentioned at the start of this e-mail: we’ve gotten our team responsible for making these resin-to-resin treatment changes looking at your photos directly. They definitely agree something’s up, but we aren’t 100% certain as to what. While it could definitely have something to do with those older supports, we are very curious to see if that totally does the trick. It’s possible there’s something up on a software level here, but if there is, it’s going to take some advanced digging (and time) to find out.

“Our team will be running some test prints using your smokestack file and some of our on within our HQ print farm. In the meantime, Please do try a print of one of these smokestacks with re-generated supports. If the results don’t improve from support re-generation, we’ll know that this is only a piece of the overall puzzle of what’s going on.”

Understand totally. I too have run into issue with the supports not being liked by Preform. My issue is that my parts are so small that large touch points will overwhelm the pieces which have very thin walls thus causing holes.
The other side for me is consumable costs. Trying to solve the issue I’m having over the last week has cost me $500+ never mind the lost production time.

As I said earlier, I bought the DIGI Tech S-Box today and it’ll be hear next Tuesday. I have a Commercial Silver Bullet die cutter I want to get rid of and I’ve already had someone say they are interested in that. That’ll give me the room for the S-Box.

1 Like

If they do such changes they should at least mention this in the update notes. All we get to know is “various bug fixes”. It’s frustrating at least and they’ve been doing it like this for years.

It’s not the first time customers experience issues after an update. How hard can it be to add a note or warning to regenerate supports?

My printer suddenly has galvo issues in the new perform. The interesting thing is that as long as I don’t print near the edge where the wiper is, the print will be successful. As soon as I print close to the edge the printer will give an error 42 and stop mid print.

I’m still having major issues with my Form 2 printers. I’ve rolled back Preform and Firmware to Ver. 2.19.3 which has worked well for me in the past. Not now it seems.

I printed 25 small delicate parts with the new Preform/firmware heated tray and such. The supports all printed real good but nothing of the parts printed. After roll-back I printed 6 of the same item and got the same results. As far as I can tell there is nothing in the reins tray of particles from the prints. Had issues with larger prints not printing well.

So, now I’m going to try printing the same parts in Open Mode, not heated resin tray. As of right now that seems to be the issue.

My solution right now is the purchase of a DIGI Tech S-BOX which will be here next week. We’ll see how that does in comparison. It has a 50% larger build plate and resin is only $30 a liter!

Might as well fill this up with more photos of the TRASH I’m producing.
First photo is prints done with the new Preform/Firmware and heated resin tray: Nothing usable.

Second photo is Old Preform/firmware and heated resin tray: again, nothing usable. Just the supports printed they were .40mm.

I’ve had the same results running the OLD Preform/firmware in OPEN MODE.

Last photo is ALW resin old Preform/firmware and OPEN MODE. at least some pieces of the prints are there.

I’ve run these same files in every combination I can come up with on two different machines. Why would BOTH machines have the same issues at the same time? They have been cleaned and the supports printed OK but not the parts. If it was a dirty galvo, mirror or glass those would be a mess also.

Possible a bad Galvo motor but again, BOTH machines at once? Maybe there’s a expropriation: date and they passed it.:rofl::face_with_symbols_over_mouth: