Form Wash blades locking up! Help!


#1

Hi there, I have just started using the formwash for the first time. But unfortunately there was an issue with it already. After the blades start spinning for a few seconds it would lock up and there is a clicking sound instead. The blades are now moving slowly or just moving due to the momentum slowly.

Everything is new, the IP is also new. There is nothing touching the blade, as I have tried with and without the basket.

Does anyone have any solution for this?


#2

If you take the blades out of the formwash (I think they’re held in and spun by magnets), does it still make the noise when you turn it on? If so, the problem is likely with the motor-side of the FormWash.


#3

Yes i tested with the blades off, the motor works. Its definitely the blades.

I tried with no Ipa. the blades run.
I tried with Ipa at 4L, the blades run. Now with basket and the blade stops after a few seconds.
I tried with Ipa at 6L, the blades stops after a few sec, with no basket.

I noticed that once there is some resistance to the water, the blade dismounts from the magnetic pull from the motor. Is there a way to slow the speed of the revolution of the motor so the blades can keep up with the speed of rotation?

Its either the magnets used on the blades are below standard or the motor is not generating enough pull. But what does that mean? Do I ask for a refund for a defective unit?

The clicky sound was the rebound of the magnets on the blades not being able to catch up to the speed of the rotation once it got going, hence it stops after the intial start


#4

You should open a support ticket. This could be something that’s easily fixable, but perhaps you will need to get a warrantee replacement.


#5

How do I open a support ticket?


#6

https://support.formlabs.com/s/contact-support?language=en_US


#7

Cool thanks for the help!