Consistent errors when trying to print Hollow Object - Form2

This may actually be more of a Meshmixer question, but I have a ZBrush object I made which I sliced up for printing and it is error-free according to PreForm, Meshmixer, and another slicing program I use for FFF printing. If I try to print it solid… no problem, however it’s a large object that I don’t want to use $75 worth of resin on. But, as soon as I hollow it out (which I’ve done many times on other objects) I get a “Print Error” as soon as I press the confirm button. If I then press ignore, it will start printing, then just stop after 50-60 layers, and still say “Printing” indefinitely.

Has anyone experienced this before? And, have any advice? I can’t figure out why it is giving the error.

FYI - I have tried a factory reset, and I’m running the latest firmware and version of PreForm.

Thanks, -Rob

well- from the look of it it appears to have a solid exterior with no openings into the hollow interior?

those large flat areas where the legs attach… are all your hidden joints solid membranes like that?

I can envision that as this shape prints it creates a huge CUP feature internally that will cause problems.
I would cut lots of openings in those flat areas around the keys to allow the resin to wash in and out with each reset of the platform.

But I don’t see why that would cause the machine to simply Stop unless its stopping because the platform can’t lift up against the suction of the cup shape.

Also- how Thick are the walls on this?

Thanks so much for the reply. I’ve tried it with holes as well. And yes, there is still a small cupping issue even with the holes, but it errors before starting to print. I didn’t however think to add holes on the leg areas. That’s a good idea. Thanks. (I had them on all the square tab areas) But… as mentioned, I’ve tried with holes and without. My preferred wall thickness is 2mm, which I’ve used successfully on most of my hollow prints. But, I’ve also tried 3mm and 4mm as well. For some reason, it’s just not liking this model as soon as I do any sort of hollowing. Weird! ???

I’ve printed several of the other parts of the model without any issues, such as the head (attached). And yes, all the parts are closed meshes as well. Thanks again for taking the time to reply. I really appreciate it.


if other prints you prep similarly are printing fine… then the problem is likely with the model.
It may have fugitive geometry, or coincident points or surfaces…

just because Preform likes a model does not mean its valid geometry- and I have had Preform assert that models I know to be perfect need ‘repair’. And seen the app import models it Thinks are fine that turn out to have all kinds of internal flaws.

If your app has a “fill Voids” option or object doctor- try running the model thru that… _ do it both before and After hollowing the model just to insure that the offset operation doesn’t create a void.

co-incident points or geometry can occur when a model is tesselated from surfaces or 4 point geometry to 3 point geometry. This is usually due to a rounding error because the modeling space can deal with more decimal places in terms of a points position than the export format is set to juggle… two close points get ‘rounded’ to the same coordinates and that can give a printer all sorts of fits.

one way I have gotten around such errors in the past is to scale the model UP by 200%, say, and then export it… and then scale it back down once imported into the printer. this helps avoid aliasing that can occur when exporting to a different file format than an app’s native format.

Yeah, it has to be the geometry, but it would be great if the Form2 actually gave an error code instead of “Print Error”. I’ve tried every fix utility there is inside Meshmixer, such as “Close Cracks” and “Make Solid”, both before and after hollowing and adding holes, all resulting in the same Print Error.

The models is definitely made up of tris. I dynameshed in ZBrush after splitting up the parts for printing, then later decimated the parts for printing. (was a 43 million poly model / now roughly 2), then exported from ZBrush to an .stl. I really hate taking it back into ZB, but I guess I’ll try to re-dynamesh which will re-mesh it completely and theoretically fix any holes or bad geo. The only problem with that is that ZB uses a convoluted scaling system that means absolutely nothing for other programs, so I hope to god I can rescale properly when I take it back into Meshmixer to hollow and add holes. :slight_smile:

Anyway, I’ll post an update after I try that out. -Got another part finishing up printing right now, so I’ll have to wait a few hours. Thanks again so much for the help. I really appreciate it. I’ve been 3d modeling for about 20 years and know my way around that part pretty well, but am still pretty new to the Form2 and Meshmixer.

Thanks again! -Rob

I feel your pain over zBrush’s incoherent dimensioning methods…

if its a problem… I run Freeform- it makes any file a perfect solid on import…
If you PM me a dropbox link to the highest res version you have of the model, I can open it, -re-export it and link it back to you.
it would be better to send the 43million poly file as I would likely import it closer to 150 million to ensure accuracy. Then decimate it from there to around 150mb for a printable export.

if you send the lower res file out of meshmixer- just insert a 100 mm cube or other reference object- not intersecting the model- so I can verify its scale is correct on import.

Well, I re-dynameshed then re-decimated after running every repair utility I could find in ZBrush. No errors in PreForm, but still got the “Print Error” as soon as I pressed the confirm button on the Form2 unit again. Ugh!

Just sent you a PM. Thanks.


I imported it at 3 gb resolution.

My software found 26 voids in the hollowed out body. ( not including the open interior )

I saw several telltale Puckers on the flat joint areas that looked like folded geometry that often results from zBrush tessellating its 4 point into 3 point.

I’m decimating it now back down to around 122mb- just in case the 156 mb size had anything to do with the print error.

I’ll PM you a link as soon as its done decimating.

Again, I really can’t thank you enough. I’ve tried probably 20+ variations and countless hours trying to figure out exactly why it has been hanging up to no avail.


Just in case anyone else runs into this issue, I thought I would post a follow-up.

First off though, I want to thank Sculptingman for his incredible generosity trying to figure out this issue. It’s very much appreciated. He definitely went above and beyond on this.

In the end, we still weren’t able to figure out exactly why this particular model was having errors. Even though PreForm didn’t see anything wrong with the model, there were apparently some errors in it which he graciously fixed for me, but the error message persisted no matter what. This particular model simply will not print at 25 microns for some reason. But, as soon as I switched to 50, it prints fine. I normally print everything at 25 just to get the best possible quality. 50 honestly, still looks amazing.

So that being said, still no absolute fix, or even any idea why this model kept failing, but if you’re having a consistent “Print Error” message show up on your LCD screen before the model even starts printing, maybe try lowering your print resolution. If anyone else has any thoughts to what might be happening, please let us know. I think we are both scratching our heads still.

If anyone is wondering, I am using the latest 64-bit version of PreForm and have the latest firmware installed on the Form2. The model was coming in at just under 1 million polys. -much less than many I’ve printed before without issues. I tried a factory reset as well and the only model in the Form2’s storage was this particular model.


@robpauza I suspect that it may be a memory issue - possibly PreForm is running out of memory while generating the laser paths, creating some error/malformed layer in the job file which confuses the printer. A 1 million poly model sliced down to 25 microns is going to use a lot of memory :slight_smile:

If you can DM me the model, I would love to debug it internally to see if we can figure out where PreForm is going wrong and hopefully improve it for the future.

@gtl Thanks. PM just sent.

First the model is looking awesome, however I suppose the issue is the amount of polygons. When I use the 3d print exporter in Zbrush I first decimate the model to max! 250K polygons, that amount keeps the details and get the best print results. If you think you need more details on the surface than do a project all from the original on this decimated model again, than the detail will be on the 250K polygon model. That should do the trick even with the 2mm shell thickness. Hope this helps!!!

Thanks so much for troubleshooting the model. I’m still new to ZBrush, so I will definitely give that a try next time.

Also, thanks for the compliment. The print turned out well. I’m still consistently amazed at how well the Form2 prints. I’m literally shocked every single time. :grin:

Take care. -Rob


I pretty routinely print parts that are around 100mb to 150 mb in STL…

if there is a size or polygon umber we should stay below… i would sure like to know what it is.

1 Like

Polygon are about 270K to the max in .stl format, that’s what I’ve learned so far…Don’t know why.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.