Aftermarket Form 1+ Laser Replacement

Sounds like it doesn’t have the photodiode feedback, or is just faulty.

I have replaced the diode in a Form 1 and a Form 1+, they are the same. It’s tricky as I had to dremel the rear part of the aluminium tube away to be able to remove the internals.

After a bit of research I used this diode

On my Form 1+ the front part that sets the focus was just super-glued in place, real high tech, and the optics were super cheap badly aligned, fixed with superglue again.

I can’t find the pics of the disassembled laser at the moment but will post them if I find them.

1 Like

Thanks @Firefox3d! I’ll order some of those Nichia diodes.

In the meantime, I tried to answer my own question about pinouts. I wasn’t quite ready to rip apart my laser yet, but inspecting @geggen20’s photos from a Form 1+ module and @Dudemeister’s photos from a Form 1 module, I think the Form 1+ laser module circuit might look something like this:

I’m guessing Q1 is some kind of constant current LED driver? (I couldn’t make out the markings on the chip).

I took some measurements on my Form 1+:

Pos Probe Neg Probe Voltage (idle, lid closed) Voltage (spot test)
Red Black 2.64V 4.26V
Red Yellow 11.12V 11.09V
Black Yellow 8.47V 6.81V
Blue Yellow 4.91V 3.44V

When the lid is open they all drop to near 0V.

In short, the voltage between the red and black leads controls the laser power, and the blue lead senses current from the photodiode.

Armed with all this, I was comfortable hooking my original laser up to a bench supply (positive to red, negative black) and ammeter (positive probe to blue, negative probe to black), to get some baseline characteristics:

Red Current Draw Blue (Sensed) Notes
0V 0mA 0uA
0V 0mA 0.4uA Shining a flashlight into lens
3.1V ~0mA 0.1uA Laser spot appears (very dim)
3.2V 10mA 0.1uA
3.6V 20mA 0.3uA
3.8V 30mA 0.4uA
4V 40mA 1.3uA
4.1V 50mA 14.4uA
4.2V 50mA 26.2uA Similar brightness to spot test
4.4V 60mA 46.3uA

(Module Current Draw is to nearest 10mA)

Unfortunately I didn’t get to characterize the replacement module. It just started sucking up current with no emission, leading me to believe the laser diode is shorted. When I peer into the lens I don’t notice a beamsplitter like I see in the original, although I do get a sense current on its blue lead when I shine a flashlight in.

A random bit of trivia I noticed while investigating: R1 in the voltage divider on the original Form 1 is a 1% tolerance resistor, but for the Form 1+ became a 5% tolerance one.


Q1 is a Lasorb ESD protection IC.
This picture shows the power board of the Moai laser printer, which i think uses the same laser modules.
Btw. did you take a look at the"CAL" pin header on the F1 board and how it is connected to the laser pins? I think the photodiode of the laser module should be connected to one of these pins.

This is my current understanding how the F1(+) regulates laser power:
At factory there is a calibration measurement where a voltage is applied to the laser and the optical output power gets measured with a laser power meter. Each F1 has a calibration table with 3 columns:
First column: ADC voltage from 0 to 3.3V, this probably controls a transistor that applies 0 - 5 V to the laser diode.
Second column: Optical output power in mW
Third column: Voltage measured at the photodiode in mV.
The laser table array in OpenFLs gives an example. Each F1 has its own table, that it is reporting to Preform. Laser power is only set by the pre-calibrated voltage, i think the feedback of the PD isn’t acutally used by the F1 firmware.

1 Like

I also fixed a CNC Form 1 clone which had a different driver board and Q1 chip to the Lasorb boards, it tested as just a enhanced mode N channel mosfet with a VGS of around 0.6.

BTW the mainboard of the CNC is exactly the same as a Form 1, just with CNC on it.

I wonder if that explains why I don’t see leads to a photodiode in @Dudemeister’s Form 1 board photos?

Is there any chance of hacking the tables in OpenFL to try boosting power to my laser? I tried shunting some current off the sense lead by putting a 220ohm resister between the Blue and Black wires, in hopes of getting the photodiode to “underreport” and the F1+ to “overcompensate”… but couldn’t get the F1+ to supply more than 4.28V to the laser over the Red and Black wires.

Also any idea what the optical output should be at a given voltage? I’d be curious to pick up a laser power meter and check mine.

The F1 laser module uses the internal photodiode of the laser diode. But diode manufactuers always mention in their datasheets that this PD is only for “internal use”. I think newer LDs dont even have that diode connected to the package (no 3rd leg).
Maybe because of that Formlabs added an external diode in the F1+ lasers? But i’m not sure for what this diode is actually used for.

The laser table is stored in the firmware of your F1+, so you need to change it there.
I managed to read out the firmware of my F1 with the serial header. I see no reason why it shouldn’t be possible to write the laser table, but i didnt try that yet. But i think the best way to fix your F1+ is to replace the diode in your laser module, because your present LD will degrade even faster under the increased load.
With OpenFL you could create a material profile that uses a higher laser power to “patch” your old laser.

This is the laser table of my F1, sadly i dont own a F1+:
[[0,0,0],[0.0,0.0, -0.13],[0.1,0.01, 0.49],[0.2,0.02, 1.35],[0.3,0.03, 2.29],[0.4,0.05, 3.02],[0.5,0.1, 3.54],[0.6,2.72, 9.42],[0.7,8.18, 19.26],[0.8,13.77, 29.85],[0.9,19.49, 36.63],[1.0,25.3, 47.64],[1.1,31.09, 60.4],[1.2,36.97, 71.47],[1.3,42.87, 81.91],[1.4,48.78, 92.47],[1.5,54.75, 102.44],[1.6,60.71, 112.95]]

I don’t have a voltage/current to optical output power measurement. I’m searching for a laser power meter, but they are hard to get at a reasonable price. The Coherent Laser Check would be a good option, but it is hard to get in Europe.
I have build a crappy integration sphere to measure the output of my F1, but so far the measurements are not good enough.

1 Like

I have swapped lasers old and new between 3 different printers and they all printed A ok. It might be I got lucky with that Nichia diode, but there doesn’t seem to be any need for calibration.

Forgot to respond to this before. The theory is a good one, but I did a continuity test and none of the CAL pins are directly connected to any of the Laser pins, except for Yellow chassis ground.

Thanks! You’re right, Q1, R1, R2 and C1 are all part of the ESD protection circuit, identical to the sample application in the datasheet you linked.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

I took the plunge and performed “open diode surgery” on my laser module.

I was able to scrape out all the epoxy by solely mechanical means. All you need is a sharp tool (I used a pair of fine point Hakko tweezers for most of it), and a lot of care and patience. I worked out tiny chips at a time. I found the epoxy around the wires formed a natural protective barrier that helped me avoid chaffing into them. Once all the epoxy was removed, I found pink foam stuffed in which I assume was to prevent the epoxy leaking inside, and maybe also to act as a heat insulating barrier.

With the epoxy and foam removed, I could slide the logic board most of the way out. But the end connected to the interior module got snagged at first, preventing me from removing it completely. I was going to cut away the end of the cylinder to try and get better access (you can see the beginning of the cut), but that turned out to be unnecessary. All you need to do is heat the outer metal cylinder a bit. A few seconds with my cutting tool provided sufficient heat for it to expand enough that the contents dropped out easily. I’m sure a heat gun or hairdryer would have done the trick as well (it didn’t take much expansion).

Here are some closeups of the extracted module:

The board was wrapped in heat shrink tubing which was easily cut away.

I took some measurements, and my circuit schematic a few posts back seems correct, except I missed a connection between the LDA pins. Here’s an updated schematic (thanks @Marshall_Banana for the datasheet on the Lasorb IC):

R1 was measured (in-circuit) as 120Ω, R2 as 985kΩ. A continuity test with probes on each end of D1 measured 542mV (black probe on black wire, red probe on blue wire) and nothing in the reverse direction. U1 measured as 653mV with the black probe at LDA and red at GND, and 356mV in the reverse direction. Although I believe the yellow wire is for chassis ground, there was no continuity between it and the brass barrel of the module.

Before any further disassembly, I gave the module a final test with a bench supply to make sure nothing got damaged so far. It still worked.

Then I desoldered the old laser diode from the board:

One of the photodiode wires snapped off during handling. It was easily repaired.

There are two lenses in the module. One in front of the laser diode, and one at the emitting end. You can just see the bottom edge of the former in the photo below (by peering through the gap between the photodiode and the back edge of the cutout). I think both are stuck with adhesive (glue? epoxy?). There look to be threads on the inner surface of the barrel. There’s what looks like a beamsplitter behind the emitter lens, which I presume sends some of the light to a photodiode. There’s a blue sticker or coating on top of the beamsplitter.

I think the original laser diode may have had a photodiode built into it, but if so it wasn’t being used (I think the third lead was cut).

Unfortunately I hit an obstacle trying to get the diode itself out from the back of the module. It looks like it was epoxied in place around the edges, and I suspect the fit is fairly tight. I tried heat, but was wary of overdoing it (at the time I thought the lenses were acrylic, which in retrospect was stupid, they must be glass).

Since I didn’t care about recovering the old diode, I decided to drill it out. By this point my patience was wearing, and I knew I probably ought to have set it aside to continue another day.

I was careful to make sure my drill bit didn’t enter deep enough to hit the lends behind the diode, but I guess my bit wasn’t sharp enough as the drilling force caused the diode itself to deform and crack the lens behind it. I got the diode out, but with the damaged lens the module is useless.

Until I can find a replacement module (or new lens?) that’s the end of DizzyRuff :-(.

I’m open to suggestions for resurrecting this printer if anyone has any! (Otherwise, I guess I’ll be doing a firesale on Form 1+ parts and still-shrink-wrapped resin tanks).


Was there ever any more progress on this? I’m working on some further development with OpenFL and I have some Form1+ mods planned. If you’re really done messing with this printer, I might be interested in buying it for the project. You can see what we are working on at

1 Like

I once upgraded a laser cutter to a higher laser, from oversees, When one orders a part like this , you need to make sure the wires match the replacement. (Often times, when shipped oversees they do not come wired for US) , meaning, you have to pop out the wires and replug them to match what you are trying to fix or you risk further damage.

I can see just from the first picture the wiring is wrong. this may have caused the over power. In some cases, bad wiring might destroy the entire board.

I had said it once before , when you order replacement parts ( for any machine ) from oversees, make sure the wiring matches what you are attempting to replace, often times it will not. Would this have saved the machine upfront, not sure, however it is something to note for others. Wiring is different in certain countries. It was noted above about wiring/ where the grounding wire should be… but some may not be aware of this and think replacement parts from oversees are plug and play…

I had a broken motor on my F1, ordered a replacement, turned out, it spun upside down, had to dismantle the motor and flip it so it would work. I had a laser cutter upgrade from oversees, the wiring was off and nerfed the adruino. Until I realized the wiring was off…

It seems to me, the grounding wires are usually off and need to be resorted… so make sure the replacement wiring, mimics the part you are replacing.

I am looking for a mother board for the form 1+ if anyone can help out. Also working on a laser module from a Peopoly moai, they might be close to the form 1. Does anyone know what causes flaring? I was hoping that one of the lenses became blurred and I could clean it. I have a heater and I think that it atomized resin and contaminated the laser?

Can’t help with the extra motherbotherboard but for the flaring maybe this could help if you haven’t seen it yet.

You can use a Peopoly Moai laser in a Form 1+. It’s probably more expensive than other options, but it works great and the spot size is 70 micron instead of 300 micron. You will need to use an OpenFL resin profile, but the results are worth it (my profile is on Github in the community resin profiles section of

Here is an example of the results:

I purchased the Moai laser from Peopoly. Installation was easy, and I finally managed to get the first successful prints in a long time out of my Form 1+.

This is using Grey v4:

Here’s Peopoly Model Black using OpenFL and @lavachemist’s 50um profile:

I think things are slightly overexposed. I need to see about editing the laser calibration data in the printer. Also wish Formlabs released unencrypted profiles for a few more resins other than Clear.

how did you actually get OpenFL to actually work with the material profiles? All i get is an error message.

  1. Installed Preform 2.3.3 “OpenFL” version (Windows | Mac).

  2. Used that version of Preform to update the firmware in my printer to version 1.44 “OpenFL” version.

  3. Loaded my model in that version of Preform, and loaded the custom material file.

  4. Sent print to printer like normal.

Step 2 was a little tricky as my printer never seems to want to update firmware smoothly, but after a couple tries it worked. You can check the version of firmware installed by holding down the power button for a few seconds when the printer is off (i.e. when the LCD is dark).

Hope that helps.


I eventually figured it out. There is a bug in OpenFL that triggers if you have a form1 and try to increase the power over 60mw it fails badly.

1 Like