Jagged Edges

Hi Everyone,

I am having an issue with my 3D model into Preform. When I go to import my 3D model, it comes with jagged edges. I understand that models that are made in CAD softwares are smooth due to the filters or plugins that are enabled for the sake of modeling. But the jagged edges are not apparent in Meshmixer, 3DS Max, Maya, Meshlab, Inventor, or even Microsofts 3D default print software. But for some reason once I put the model in Preform, it has those edges. I’ve tried adding/subtracting polygons/triangles to get it smoother, but it seems to have no effect. The model I bought was made in 3DS max, I made sure the model is manifold and one single mesh. It’s also able to print, but it does not look the way it needs to. Unfortunately for legal reasons I cannot post a picture of the model, but I can give you reference as to how it looks (like a low poly model.) If anybody would have any suggestions for any of the softwares listed above that could fix this problem that would be great. Thank you

I’ve also refernced this forum which was helpful with Inventor Files:

number one- you CAN post a picture of the model. No matter what the seller claims about usage- commentary in a forum asking for advice on what’s wrong with the model is “Fair Use” under copyright law.

number two- every app you list aside from meshmixer is Infamous for being great at modeling for Rendering- as in animations- but total crap for modeling for physical print.
There are Oodles of ways in which a model can Render fine- but not be able to print- or have other artifacts that are the result of being a very low polygon count model that only looks okay in rendering because of texture mapping and other means of faking a smooth surface on a model that is actually pretty rough.

In buying online models for print- pay close attention to the number of polygons listed. You want to see the largest number of polygons you can find- at least hundreds of thousands if not more.

number 3- if the model has already been triangulated, you aren’t gonna be able to do much about it being a low poly model. You can “subdivide” the mesh and that might help a little- but most triangulated models have lost the information that allows for controlled subdivision.
however- if the model was correctly modeled in s SubD modeling program, then the OBJ version ,may well have a lot of information about detailing and smoothness- SubD models can have multiple levels of subdivision that you can turn on or off for the purposes of faster workflow in animation. e.g. you don’t want to be doing posing and keyframing with a bunch of million polygon models as that slows everything down, so you dial the model down to a lower subdivision level of just a thousand polygons. And then dial the subdivsions back up when you want to actually render- since that’s gonna take forever anyway.

So if your OBJ model is an actual SubD model- it may have latent detail you can;t see because it imported at its lowest subdivision level. One clue is if the model is made of 4 sided polygons. SubD models have 4 point geometry,
If so- then try importing it into an app that supports SubD modeling and try to find the tool or command that will allow you to subdivide or divide the model. With each level of subdivision you should see more fine detail and less faceting.

1 Like

Depending on what 3D program you use you might be able to smooth it. Regular 3D software like 3ds Max use something that modifies the surface normals to make things look smooth, but for 3D printing it can’t do that because it’s just a visual effect, so a 3D print will always have a faceted look. To fix this, the model needs to be subdivided until the polygons are small enough not to be noticed in the 3D print.
In 3ds Max you can apply a Turbosmooth modifier on there and see how it turns out, but there’s going to be issues in some areas that might need fixing, it’s not going to look the same way it does as the low-poly mesh.

Just a random guess, since I can’t see what you’re seeing.

Some of the programs you’re comparing to default to interpolated shading because it looks “nice”. PreForm uses flat shading to ensure that you can really see the facets. That’s to make sure it’s not hiding something that will be important in your print quality.

For example, in MeshMixer, if you go to the Preferences panel, you see these choices:


The “Face Normals” option should show the same thing PreForm does. If you’re using one of the other two, then a mesh will look different from PreForm, even if it is exactly the same geometry.

1 Like

face normals is not going to show faceting, necessarily- All STL modeling uses the Actual normal which is a line perpendicular to the plane of the polygon at its centroid facing right hand rule to the visible side of the polygon.
Smooth shading is a graphics card trick that measures the incidence of light sources to each normal on each face and simply creates a Gradient of shading between normals that has nothing to do with the actual geometry of the model. THis can make a faceted surface appear smooth ( except in profile- where the facets will still be visible. )

Most animation models are intentionally made to have the fewest polygons possible- for speed of animating and rendering- with the Apparent shape and detail generated by texture and color maps that simply affect how the ray tracing engines light the model.

Some apps, like zBrush, enable you to do what looks like very detailed modeling by using texture maps to simulate detail without the necessary computational load of actual geometry- however- they offer the option of “Baking” those texture maps into Real geometry when you are ready to export- creating much larger files with millions of polygons.

If the model was made in SubD- then some of this texture information is still in the OBJ file- its just that it will naturally import at its lowest resolution. Import the model into a SubD capable modeler- and you should be able to subdivide the model to reveal a lot more detail.

But if its just a Low Poly Gamers model with no subD infromation- one that relies on color mapping and phong smoothing- then the OP is pretty much out of luck.
Subdividing will make everything look like it was sanded- but will lose any crisp detail as well.

Hey Everyone,

Thank you guys for all of your input! The subdivision of the polygons that Sculptingman had suggested worked. I checked my model’s polygon count and it was in the hundreds of thousands. I brought my model into 3DS Max (where it was made) and followed the tutorial linked below. I then exported the model as the highest quality STL and threw it in Preform. The model in there was perfectly smooth! I also had this same issue while exporting STL’s from Autodesk Inventor. To solve this, I exported the STL at the absolute HIGHEST quality level possible, it created a large file but it was what I needed. Both models are exactly how they appear in their non-faceted form. Again I can’t thank you guys enough for helping me solve this problem.

Subdivison Tutorial:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.