IC U12 Information

I received a Form1+ from a coworker and in updating the printer to the latest firmware and moving, I have found that the printer no longer is being recognized by my PC. I have tried connecting it to different windows machines and a mac with no luck.

I investigated and found that the D+ pin is shorted to ground on my USB connector. I have been probing around and have a suspicion that I somehow damaged U12 on the board. I couldn’t read the top of my part but i did find a nice picture on the OpenFL github that shows the text. Can any of you with a Form 1+ take a picture of your board or let me know if the text on the top of U12 is the same as what is on the picture below?

I believe it is the ESD protection for the USB port and am trying to determine what the part number is. I believe it to be a TI TPDE001 part. Any help would be appreciated.




Two months ago I purchased TIG pulse welder Orion 150i and it came out that there was no connection to the main unit. During the repair it came out that the USB protective IC was not OK (USB data+ line was to GND), replacing the part resolved the problem. As I see you have similar IC around USB, same number of pins and same package - it’s quite possible it’s the same or simal IC as USBUF02W6 - see attached data sheet.
USBUF02W6.pdf (188.1 KB)

You can purchase the part from Farnell.

@luben111 Thanks for the info.

My concern is the Pinout difference for your IC and the one found on the Form1+ main board.

Just looking at the datasheet for the TI part https://www.ti.com/lit/ds/symlink/tpd4e001.pdf?HQS=TI-null-null-digikeymode-df-pf-null-wwe&ts=1597287994219 shows it has several different versions with different pinouts. I think i will have to measure the dimensions of the package to determine which one it is since the different versions are using different package sizes.



The slow project to reverse-engineer the Form 1 motherboard on the forums continues, one chip at a time :stuck_out_tongue:

I can confirm that U12 is the TI TPD4E001. The package is listed as DRL6, which I believe means it’s the SOT-5x3 / DRL package, e.g. the TPD4E001DRLR.

I’m a little late but happened to be going into my Form 1+ today, here’s a good photo of it in-circuit (click a couple times to zoom in):


With high probability replacing the part with TPD4E001 will fix the problem. But I have another concern - maybe the grounding of your printer or your computer is not OK, ideally when printer and computer are not connected via USB cable you should measure low resistance (<3 Ohm) between printer and computer chassis. If you can’t measure such low resistance - you need to check your power line connectors.

From my own experience I know that these USB protective diodes can’t burn out easily from simple ESD discharge, you need much stronger power to burn them out.

I measured the IC this morning and the dimensions matched the DRL package of the TI part. Looks like im late.

@MattKeeter Thanks for confirming the part. It would be a shame to trash a perfectly good printer over a component here and there.

@luben111 Yes I am still worried about there being some other culprit that caused the failure. I did check my old computer and noticed that the USB port I was connecting to has somehow lost the plastic that is the backing for the USB so that may have caused something to short together and blow U12

I will update here if it fixes the problem.

Well got the new ESC chip soldered onto the board and it worked. Printer was immediately recognized when i connected it back to my PC. I wonder what I did to zap the chip the first time? Anyway, thanks again @MattKeeter for confirming the part.